Some tasks disappear when GTG is not properly exited

Bug #317033 reported by Bertrand Rousseau on 2009-01-14
4
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Unassigned

Bug Description

Some tasks disappear when you exit GTG by interrupting the process.

To reproduce:

1) start GTG in a shell (for instance on test data)
2) hit Ctrl+C in the shell
3) restart GTG

Some tasks have disappeared

Related branches

Changed in gtg:
importance: Undecided → Medium
milestone: none → 0.1rc
status: New → Confirmed

I must add, when it crashes, it also loose all the parent/children relations

The parent/children relation is not lost anymore. Can you try to identify what are the lost task ?

On my side, when crashing GTG, the only notable effect is that the task "enfant3" is reset to a blank task. It's strange because it's the only one. Task don't disappear at all.

Ok, the only task which is modified is the last one of the XML file. Don't ask me why !

fixed in rev.84 You should really not have any problem now. I really believe that we have now a rock solid sync mechanism. Even if you have a crash when editing a task, the task will be restored !

Changed in gtg:
status: Confirmed → Fix Released
Changed in gtg:
assignee: nobody → ploum
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers