Error when opening Preferences dialog

Bug #1265979 reported by Andriy Kovtun on 2014-01-04
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Parin Porecha

Bug Description

Version: gtg 0.3.r1332~ubuntu12.04.1
OS: Ubuntu 12.04.1
DE: KDE 4.12
I get this error when simply open Preferences dialog.
Previous version worked properly.

Traceback (most recent call last):
  File "/usr/share/gtg/GTG/gtk/browser/", line 416, in open_preferences
  File "/usr/share/gtg/GTG/gtk/", line 239, in open_preferences
  File "/usr/share/gtg/GTG/gtk/", line 144, in activate
  File "/usr/share/gtg/GTG/gtk/", line 129, in _refresh_preferences_store
  File "/usr/share/gtg/GTG/gtk/", line 214, in refresh_accel
    self.new_task_binding = get_saved_binding()
  File "/usr/share/gtg/GTG/tools/", line 50, in get_saved_binding
    list_keys = call_subprocess(CHECK_VERSION).splitlines()
  File "/usr/share/gtg/GTG/tools/", line 160, in call_subprocess
    out = subprocess.Popen(cmd, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
  File "/usr/lib/python2.7/", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/", line 1249, in _execute_child
    raise child_exception
OSError: [Errno 2] Нет такого файла или каталога

Related branches

Parin Porecha (parinporecha) wrote :

Hi Andriy,

can you please run 'which gsettings' on your computer and tell me the output ?
(I think you're facing this bug because your $PATH variable does not contain the directory where the gsettings executable is)

Changed in gtg:
status: New → Triaged
importance: Undecided → Low
importance: Low → Medium
assignee: nobody → Parin Porecha (parinporecha)
milestone: none → 0.3.2
Andriy Kovtun (kovtunos) wrote :

Hi Parin,

$ which gsettings
gsettings not found

Thanks for hint!
I just installed libglib2.0-bin that contains gsettings executable.
Preferences dialog now opens correctly.

Parin Porecha (parinporecha) wrote :

I'll update the preferences dialog to at least disable the custom shortcut option when gsettings is not installed

Parin Porecha (parinporecha) wrote :

Fixed in revision 1343

Changed in gtg:
status: Triaged → Fix Committed

This is still an issue in Version 0.3.1 though.
Running Debian GNU/Linux 8.7 (jessie) and installed via Synaptic and standard repositories.
Exact same error message as above when trying to open Preferences dialog. Issue solved when manually installing libglib2.0-bin (and dependencies)

Jeff Fortin Tam (kiddo) on 2020-12-29
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers