GTG

Update Evolution backend to use GTK3 gobject-introspection bindings

Bug #1262972 reported by Ankur Sinha on 2013-12-20
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GTG
Medium
Unassigned

Bug Description

Hi,

This is probably another task related to porting gtg to GTK3. The evolution backend also needs to be ported. The python2 bindings for evolution no longer work with the new versions of EDS.

This is the response I received when I requested information on the python2 bindings for evolution on the fedora-desktop mailing list:

https://lists.fedoraproject.org/pipermail/desktop/2013-November/008473.html

"If you look at the changelog from the package you'll see that the
evolution extension has been dropped. This is because the
gnome-python2-desktop bindings are written with gtk2 and evolution
needs gtk3. For all gtk3 apps you'll need to use the automatically
generated gobject-introspection bindings which evolution-data-server.

So ultimately just packaging it up won't fix the problem, you'll need
to have gtk3 support for it.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=465567"

Here is the referred Changelog entry:

"* Sat Jul 28 2012 Kalev Lember <email address hidden> - 2.32.0-12
- Obsolete the dropped gnome-python2-evolution subpackage

* Fri Jul 27 2012 Colin Walters <email address hidden> - 2.32.0-11
- Drop evolution bindings; they don't build against the latest EDS"

I already see work being done to port GTG to GTK3. Updating the evolution backend too would be great for users. Currently, GTG does not work with evolution at all on my Fedora 20 system

[asinha@ankur-laptop ~]$ rpm -q evolution
evolution-3.10.3-1.fc20.x86_64
[asinha@ankur-laptop ~]$ rpm -q evolution-data-server
evolution-data-server-3.10.3-1.fc20.x86_64
[asinha@ankur-laptop ~]$ rpm -q gtg
gtg-0.3.1-1.fc20.noarch

The related question I asked is here: https://answers.launchpad.net/gtg/+question/240070

Thanks,
Ankur

Changed in gtg:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.4
Izidor Matušov (izidor) on 2015-03-15
tags: added: github
Khurshid Alam (khurshid-alam) wrote :

Is there any progress on this? This project seems dead.

Hi Khurshid,
There is no active development being undertaken in GTG as of now. We will
be open to anyone coming forward to take the project further. But as of
now, the project is dormant.

Nimit Shah

On Wed, Oct 26, 2016 at 2:43 PM, Khurshid Alam <email address hidden>
wrote:

> Is there any progress on this? This project seems dead.
>
> --
> You received this bug notification because you are subscribed to Getting
> Things GNOME!.
> Matching subscriptions: bugs
> https://bugs.launchpad.net/bugs/1262972
>
> Title:
> Update Evolution backend to use GTK3 gobject-introspection bindings
>
> Status in Getting Things GNOME!:
> Confirmed
>
> Bug description:
> Hi,
>
> This is probably another task related to porting gtg to GTK3. The
> evolution backend also needs to be ported. The python2 bindings for
> evolution no longer work with the new versions of EDS.
>
> This is the response I received when I requested information on the
> python2 bindings for evolution on the fedora-desktop mailing list:
>
> https://lists.fedoraproject.org/pipermail/desktop/2013-
> November/008473.html
>
> "If you look at the changelog from the package you'll see that the
> evolution extension has been dropped. This is because the
> gnome-python2-desktop bindings are written with gtk2 and evolution
> needs gtk3. For all gtk3 apps you'll need to use the automatically
> generated gobject-introspection bindings which evolution-data-server.
>
> So ultimately just packaging it up won't fix the problem, you'll need
> to have gtk3 support for it.
>
> [1] http://koji.fedoraproject.org/koji/buildinfo?buildID=465567"
>
> Here is the referred Changelog entry:
>
> "* Sat Jul 28 2012 Kalev Lember <email address hidden> - 2.32.0-12
> - Obsolete the dropped gnome-python2-evolution subpackage
>
> * Fri Jul 27 2012 Colin Walters <email address hidden> - 2.32.0-11
> - Drop evolution bindings; they don't build against the latest EDS"
>
> I already see work being done to port GTG to GTK3. Updating the
> evolution backend too would be great for users. Currently, GTG does
> not work with evolution at all on my Fedora 20 system
>
> [asinha@ankur-laptop ~]$ rpm -q evolution
> evolution-3.10.3-1.fc20.x86_64
> [asinha@ankur-laptop ~]$ rpm -q evolution-data-server
> evolution-data-server-3.10.3-1.fc20.x86_64
> [asinha@ankur-laptop ~]$ rpm -q gtg
> gtg-0.3.1-1.fc20.noarch
>
> The related question I asked is here:
> https://answers.launchpad.net/gtg/+question/240070
>
> Thanks,
> Ankur
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/1262972/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers