GTG crashes on start with IndexError: tuple out of range

Bug #1218093 reported by aslam karachiwala on 2013-08-28
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Critical
Parin Porecha

Bug Description

v. 0.3.r1307~raring1
Ubuntu 13.04

GTG crashes (after the latest update):
===
$ gtg
2013-08-28 17:59:58,678 - WARNING - __init__:__init__:74 - Backend backend_mantis could not be loaded: No module named suds.client
2013-08-28 17:59:58,757 - WARNING - __init__:__init__:74 - Backend backend_evolution could not be loaded: No module named evolution
Traceback (most recent call last):
  File "/usr/bin/gtg", line 89, in <module>
    main()
  File "/usr/bin/gtg", line 85, in main
    sys.exit(gtg.main(options, args))
  File "/usr/share/gtg/GTG/gtg.py", line 123, in main
    manager = Manager(req)
  File "/usr/share/gtg/GTG/gtk/manager.py", line 75, in __init__
    self.browser = TaskBrowser(self.req, self)
  File "/usr/share/gtg/GTG/gtk/browser/browser.py", line 125, in __init__
    self.restore_state_from_conf()
  File "/usr/share/gtg/GTG/gtk/browser/browser.py", line 521, in restore_state_from_conf
    self.vtree_panes['active'].collapse_node(path)
  File "/usr/lib/python2.7/dist-packages/liblarch_gtk/__init__.py", line 246, in collapse_node
    node_id = llpath[-1].strip("'")
IndexError: tuple index out of range
===

Related branches

Izidor Matušov (izidor) on 2013-08-30
Changed in gtg:
status: New → Confirmed
milestone: none → 0.3.1
importance: Undecided → Critical
assignee: nobody → Parin Porecha (parinporecha)
Parin Porecha (parinporecha) wrote :

Please ignore the previous comment ( now it's gone ) and the previous mail ( if you received ).

The error is caused due to bugs in config parser.
Because malformed tags were being written in '~/.config/gtg/gtg.conf', many GTG versions were showing this same bug while parsing the conf file.
It is also causing errors in an other function dealing with TagTree in sidebar.

I'm working on it

ETA of patch: 1 week

Nimit Shah (nimit-svnit) wrote :

Hi Parin,
Please have a look at this branch: lp:~qcxhome/gtg/bugfix-1218708
It was linked to a bug which is marked as duplicate of this one.
Maybe it can help you.

Parin Porecha (parinporecha) wrote :

Hi Nimit,

I saw the branch when it was proposed for merging. ( The user has removed the it )
It's patch solved the specific bug, but didn't address the problem lying in parsing config file due to which the bug was caused.

Thanks for noticing it :-)

Nimit Shah (nimit-svnit) on 2013-09-04
Changed in gtg:
status: Confirmed → Fix Committed
aslam karachiwala (akwala) wrote :

Confirming that it's fixed in the following upgrade:
gtg (0.3.r1307~raring1 => 0.3.r1308~ubuntu13.04.1)

Thanks!

summary: - IndexError: tuple out of range
+ GTG crashes on start with IndexError: tuple out of range
Nimit Shah (nimit-svnit) on 2013-11-25
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers