[regression] Notification area applet can't display attention icon

Bug #1076029 reported by Christine Burnham on 2012-11-07
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Izidor Matušov

Bug Description

Steps to reproduce:
1) Enable Notification area plugin
2) Set a due date of a task to tomorrow (to activate attention mode of the plugin)

Expected result: the icon changes
Actual result: the icon disappears

Hi, which distribution / desktop environment are you using?

Hello, I'm using x86_64 Ubuntu 12.04 precise with Gnome Fallbackversion

Burnham Studio
Christine Burnham
<email address hidden>
617.939.0149 - 978.808.0883

www.burnhamstudio.com

On 11/07/2012 01:03 PM, Antonio Roquentin wrote:
> Hi, which distribution / desktop environment are you using?
>

I can't reproduce it (yet) on ubuntu 12.04 with gnome classic. Could you run gtg from a terminal in debug mode (gtg --debug) and append the output as the indicator applet crashes? Also please post any relevant lines from ~.xsession-errors.

Izidor Matušov (izidor) on 2012-11-09
Changed in gtg:
status: New → Incomplete
Christine Burnham (cburnham) wrote :
Download full text (4.5 KiB)

~$ gtg --debug
2012-11-09 15:33:48,013 - DEBUG - gtg:core_main_init:139 - Debug output enabled.
2012-11-09 15:33:48,035 - DEBUG - __init__:__init__:68 - Backends found: ['backend_rtm', 'backend_gnote', 'backend_evolution', 'backend_twitter', 'backend_launchpad', 'backend_localfile', 'backend_tomboy', 'backend_mantis', 'backend_identica']
2012-11-09 15:33:48,858 - WARNING - __init__:__init__:77 - Backend backend_twitter could not be loaded: No module named tweepy.models
2012-11-09 15:33:49,940 - WARNING - __init__:__init__:77 - Backend backend_mantis could not be loaded: No module named suds.client
2012-11-09 15:33:50,133 - DEBUG - datastore:new_tag:129 - *** tag added @Purchase ***
2012-11-09 15:33:50,133 - DEBUG - datastore:new_tag:129 - *** tag added @EmailsToSend ***
2012-11-09 15:33:50,134 - DEBUG - datastore:new_tag:129 - *** tag added @Work ***
2012-11-09 15:33:50,134 - DEBUG - datastore:new_tag:129 - *** tag added @Clothes ***
2012-11-09 15:33:50,134 - DEBUG - datastore:new_tag:129 - *** tag added @SRS ***
2012-11-09 15:33:50,134 - DEBUG - datastore:new_tag:129 - *** tag added @FriendsAndFamily ***
2012-11-09 15:33:50,134 - DEBUG - datastore:new_tag:129 - *** tag added @PhoneCallsToMake ***
2012-11-09 15:33:50,135 - DEBUG - datastore:new_tag:129 - *** tag added @Financial ***
2012-11-09 15:33:50,135 - DEBUG - datastore:new_tag:129 - *** tag added @WebPage ***
2012-11-09 15:33:50,135 - DEBUG - datastore:new_tag:129 - *** tag added @Computer ***
2012-11-09 15:33:50,135 - DEBUG - datastore:new_tag:129 - *** tag added @Education ***
2012-11-09 15:33:50,136 - DEBUG - datastore:new_tag:129 - *** tag added @Transition ***
2012-11-09 15:33:50,136 - DEBUG - datastore:new_tag:129 - *** tag added @Travel ***
2012-11-09 15:33:50,136 - DEBUG - datastore:new_tag:129 - *** tag added @SomedayMaybe ***
2012-11-09 15:33:50,136 - DEBUG - datastore:new_tag:129 - *** tag added @Personal ***
2012-11-09 15:33:50,137 - DEBUG - datastore:new_tag:129 - *** tag added @Self ***
2012-11-09 15:33:50,137 - DEBUG - datastore:new_tag:129 - *** tag added @BurnhamStudio ***
2012-11-09 15:33:50,137 - DEBUG - datastore:new_tag:129 - *** tag added @Home ***
2012-11-09 15:33:50,137 - DEBUG - datastore:new_tag:129 - *** tag added @Art ***
2012-11-09 15:33:50,138 - DEBUG - datastore:new_tag:129 - *** tag added @Reading ***
2012-11-09 15:33:50,138 - DEBUG - datastore:new_tag:129 - *** tag added @Health ***
2012-11-09 15:33:50,138 - DEBUG - datastore:new_tag:129 - *** tag added @SubstituteTeaching ***
2012-11-09 15:33:50,138 - DEBUG - datastore:new_tag:129 - *** tag added @Waiting ***
2012-11-09 15:33:50,138 - DEBUG - datastore:new_tag:129 - *** tag added @Movies ***
2012-11-09 15:33:50,139 - DEBUG - datastore:new_tag:129 - *** tag added @AreasOfFocus ***
2012-11-09 15:33:50,139 - DEBUG - datastore:new_tag:129 - *** tag added @Business ***
2012-11-09 15:33:50,139 - DEBUG - datastore:new_tag:129 - *** tag added @Auto ***
2012-11-09 15:33:50,139 - DEBUG - datastore:new_tag:129 - *** tag added @Marketing ***
2012-11-09 15:33:50,140 - DEBUG - datastore:new_tag:129 - *** tag added @1 ***
2012-11-09 15:33:50,140 - DEBUG - datastore:new_tag:129 - *** tag added @Volunteer ***
2012-11-0...

Read more...

Izidor Matušov (izidor) wrote :

Hm... there is nothing interesting in the log. What do you mean by "restart of gnome panel resolves"? How do you restart gnome panel?

So you say that an icon of GTG disappears but not the menu for that indicator? Could you please make a screenshot of it? I have a trouble to imagine it.

Christine Burnham (cburnham) wrote :

I'll use the 'killall gnome-panel" to restart gnome panel.

Christine Burnham (cburnham) wrote :

Then after I open a new task or an existing one the indicator disappears (but still works...)

Weird. What about ~.xsession-errors? Do you see anything suspicious there as the icon disappears?

Christine Burnham (cburnham) wrote :

Here are some at the end of the file in ~.xsession-errors
_

2012-11-11 19:07:42,053 - WARNING - __init__:__init__:77 - Backend backend_twitter could not be loaded: No module named tweepy.models
2012-11-11 19:07:42,499 - WARNING - __init__:__init__:77 - Backend backend_mantis could not be loaded: No module named suds.client
gnome-session[2604]: WARNING: Application 'gnome-panel.desktop' killed by signal
** Message: using fallback from indicator to GtkStatusIcon
** Message: applet now embedded in the notification area

(gnome-panel:8127): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion `width >= 0' failed

(gnome-panel:8127): Gtk-WARNING **: PanelToplevel 0x2388360 reported min size 1034702181 and natural size 32675; natural size must be >= min size
** Message: moving back from GtkStatusIcon to indicator
~
Thanks!
** Message: applet now removed from the notification area

(gtg:7822): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

Christine> I was able to reproduce it. It is a regression introduced by me :/ in revision 1239. Thank you for reporting it!

summary: - gtg "Indicator Applet"crashes opening new task
+ Notification area applet can't display attention icon
Changed in gtg:
status: Incomplete → In Progress
importance: Undecided → High
assignee: nobody → Izidor Matušov (izidor)
milestone: none → 0.3.1
tags: added: plugin
removed: applet
description: updated
Izidor Matušov (izidor) on 2012-11-13
summary: - Notification area applet can't display attention icon
+ [regressionNotification area applet can't display attention icon
summary: - [regressionNotification area applet can't display attention icon
+ [regression] Notification area applet can't display attention icon
tags: added: regression
Changed in gtg:
status: In Progress → Fix Committed
Izidor Matušov (izidor) on 2012-11-13
Changed in gtg:
status: Fix Committed → In Progress
Christine Burnham (cburnham) wrote :

Glad I was able to help Izidor - Thanks again and love the software!

Sorry Izidor, this bug was really annoying for me so I got it fixed in the meantime, see related branch. Unless you have already worked on it, would you consider it for merging? BTW I assume the problem only appears when using the libindicator api.

Izidor Matušov (izidor) wrote :

Antonio> I am sorry, I frogot about this bug. I solved the problem by installing GTG icons to /usr/share/icons where all icons should be placed. It should work now.

Fixed in rev. 1286.

Changed in gtg:
status: In Progress → Fix Committed
Andres (arnirim) wrote :

It looks like it is still happening on 13.04, I used the workaround described in https://bugs.launchpad.net/gtg/+bug/1079589/comments/4 and it worked.

Andres (arnirim) wrote :

Also workaround #13 described in this page works in Xubuntu 13.04

Nimit Shah (nimit-svnit) on 2013-11-25
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers