A double hyphen in the description area can make GTG crash

Bug #1062979 reported by Francesco Turco on 2012-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Izidor Matušov

Bug Description

I'm using GTG 0.2.9 on a Gentoo Linux system. I noticed I can make GTG crash if I write a double hyphen "--" in the description area of a task and then press the enter key. At this point GTG will complain with the following error message:

It looks like an error has occurred. GTG0.2.9 has crashed. Please report the bug on our Launchpad page. If you have Apport installed, it will be started for you.

Details:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/GTG/gtk/editor/taskview.py", line 1160, in _insert_at_cursor
    self.insert_indent(self.buff,end_i,1,enter=True)
  File "/usr/lib64/python2.7/site-packages/GTG/gtk/editor/taskview.py", line 947, in insert_indent
    list_stag = start_i.get_toggled_tags(False)
AttributeError: 'bool' object has no attribute 'get_toggled_tags'

If I click on "Ignore the error", it seems that I can continue working with GTG as nothing happened at all.

The reason I wrote a double hyphen is that I was trying to separate text with a sort of horizontal line.

I can reproduce this behaviour every time, even if I start from scratch, that is by removing everything in ~/.local/share/gtg and ~/.config/gtg and starting GTG as if it was just installed.

I'm happy to provide other details or run other tests if needed.

Izidor Matušov (izidor) wrote :

I reproduce this bug with GTG 0.2.9 but I can't reproduce it in the current development version of GTG -- it is fixed there. Closing as Fix Committed.

Changed in gtg:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Izidor Matušov (izidor)
milestone: none → 0.3
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers