Urgency coloring should always be enabled when a task is due today or overdue

Bug #1039655 reported by Roquentin on 2012-08-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Low
Wolter Hellmund

Bug Description

Another minor issue with the urgency color plugin.

As discussed in the original report (Bug #906516), the plugin won't color tasks whose start date is undefined, even if the due date *is* defined. My understanding is that, if a user does not set the start date, he doesn't need to be alerted in advance. However, on the due date, the task needs attention! No matter if I set the start date or not, a task due today or overdue should be highlighted, in my opinion.

Possible solutions:

(a) let the danger zone always include the due date, even if no start date is provided

(b) modify GTG so that start date is set "automatically" (i) through an option in the preferences or (ii) on a per-task basis through an additional entry in the right-click menu: "Set due date (and start today)"

Related branches

summary: - Urgency coloring should ignore start date if task is due today or
+ Urgency coloring should always be enabled when a task is due today or
overdue
Nimit Shah (nimit-svnit) wrote :

The task whose due date is passed already becomes bold.
Also if the person is using work view he will be seeing that task at the top and hence will be aware that the due date has passed.

Another thing, if the person is using the plugin, he will be aware of the fact that the task without a start date will not be colored and hence he will put a start date to keep a track.

Nimit Shah (nimit-svnit) on 2012-11-09
Changed in gtg:
status: New → Won't Fix

On 10/15/2012 06:11 AM, Nimit Shah wrote:
> The task whose due date is passed already becomes bold.
> Also if the person is using work view he will be seeing that task at the top and hence will be aware that the due date has passed.

I see what you mean, still from the point of view of the plugin the
behavior is inconsistent. And if you rely on the plugin for visual
marking of tasks, it can be misleading.

> Another thing, if the person is using the plugin, he will be aware of
> the fact that the task without a start date will not be colored and
> hence he will put a start date to keep a track.

Not really, this is not specified anywhere. Actually, I "discovered"
this fact using the plugin, I was not aware of it in advance. And I
missed a task which was due on that day.

Izidor Matušov (izidor) wrote :

Reopening the bug.

Changed in gtg:
status: Won't Fix → Confirmed
milestone: none → 0.4
importance: Undecided → Low
Wolter Hellmund (wolterh) wrote :

I am sorry, I was unaware of this bug until you (Antonio) mailed me about it, I will implement solution (a) but I think (b) is a better idea. I cannot implement (b) though for this is a feature of major importance, and should be dealt with by some of the GTG masterminds (namely Izidor haha)

Wolter Hellmund (wolterh) wrote :

I have pushed a fix to the branch I have now set as related to this bug. Antonio, please test the commit I have made and see if it fixes this bug.

Changed in gtg:
assignee: nobody → Wolter Hellmund (wolterh)

Yes, it fixes the problem.

There is only one small issue with fuzzy dates: I have many tasks due "someday", which I simply want to shift down the ordered list of my tasks, and now they are all colored as normal ones.

I believe these tasks should be colored like those of Low priority - they are not tasks you are supposed to work right now (and they don't appear in WorkView). What do you think?

Perhaps having fuzzy dates "someday", "soon" and "now" colored as Low, Normal and High priority tasks respectively (as suggested long ago in reply to Francesco Turco btw!).

Wolter Hellmund (wolterh) wrote :

@2013-02-08 18:15 - Antonio Roquentin:
> Yes, it fixes the problem.
>
> There is only one small issue with fuzzy dates: I have many tasks due
> "someday", which I simply want to shift down the ordered list of my
> tasks, and now they are all colored as normal ones.
>
> I believe these tasks should be colored like those of Low priority -
> they are not tasks you are supposed to work right now (and they don't
> appear in WorkView). What do you think?
>
> Perhaps having fuzzy dates "someday", "soon" and "now" colored as Low,
> Normal and High priority tasks respectively (as suggested long ago in
> reply to Francesco Turco btw!).
I don't know if I'd rather have those types of tasks without any
colouring at all. See, the urgency colour functionality was intended for
tasks that were meant to be completed on a defined date. This way,
important tasks stand out from the rest. What do you think?

Wolter Hellmund (wolterh) wrote :

Well today I changed my mind and gave a go at your request, so the feature is now implemented! (The fuzzy date urgency colouring). The feature however is published in the branch lp:~wolterh/gtg/urgency_gradient

Changed in gtg:
status: Confirmed → Fix Committed

There is a glitch in get_node_bgcolor(). Basically, if a task has no start date then the following test is passed

elif (sdate == Date.no_date() != ddate):
      return self._get_color(1) # Normal

and fuzzy dates are not tested at all since the function returns right away. Hence tasks with fuzzy dates (which usually have no start date) are always colored Normal.

Nimit Shah (nimit-svnit) on 2013-12-10
Changed in gtg:
status: Fix Committed → Fix Released
milestone: 0.4 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers