GTG unnests subtasks occasionally

Bug #1038715 reported by Craig Jennings on 2012-08-19
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Izidor Matušov

Bug Description

I'm using Getting Things Gnome! 0.2.9, which i received from the stable ppa. I'm running Ubuntu 12.04 LTS (Precise Pangolin)

Sometimes, I'll launch GTG and the subtasks aren't attached to their parent tasks any longer. This is troublesome since I usually use parent/child relationships to break down large projects into smaller ones. When the child tasks aren't associated any longer, I can't figure out which project they relate to.

I've been trying to isolate this to a specific action I'm taking, but can't seem to figure out what's triggering this. However, happens frequently for me. I would be happy to send you my gtg directory if you can't seem to reproduce.

Matt Lavin (matt-lavin) wrote :

I see the same problem as well. I found this bug while searching for duplicates before reporting it myself.

Changed in gtg:
status: New → Confirmed
Izidor Matušov (izidor) wrote :

Could you try the current development version of GTG and liblarch? You can use our GTG Daily PPA if you are on Ubuntu/Debian-based system: https://launchpad.net/~gtg/+archive/gtg-daily

Other people who were able to reproduce it on GTG 0.2.9 weren't able to reproduce it on current development GTG. If you do so, please tell me how you do it :)

Changed in gtg:
status: Confirmed → Incomplete

Thank you Izidor. I'll grab the latest daily build today and let you know
soon.

On Tue, Sep 18, 2012 at 6:01 AM, Izidor Matušov <email address hidden>wrote:

> Could you try the current development version of GTG and liblarch? You
> can use our GTG Daily PPA if you are on Ubuntu/Debian-based system:
> https://launchpad.net/~gtg/+archive/gtg-daily
>
> Other people who were able to reproduce it on GTG 0.2.9 weren't able to
> reproduce it on current development GTG. If you do so, please tell me
> how you do it :)
>
> ** Changed in: gtg
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1038715
>
> Title:
> GTG unnests subtasks occasionally
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/1038715/+subscriptions
>

Izidor Matušov (izidor) wrote :

I couldn't reproduce this problem with the current trunk + python-liblarch and Craig hasn't reported any problem either. Closing as a fixed problem.

Changed in gtg:
status: Incomplete → Fix Committed
importance: Undecided → Medium
assignee: nobody → Izidor Matušov (izidor)
milestone: none → 0.3
sergio (serge-simon) wrote :

Same problem for me. I wasn't unaware of this behavior so i had a lot of subtasks, all gone.
I'm using the very latest gtg-daily PPA, so the problem is absolutely not closed.

Changed in gtg:
status: Fix Committed → Fix Released
Izidor Matušov (izidor) wrote :

sergio: Are you able to reproduce this behavior? (I use subtasks quite heavily and without success) If so, I'll reopen the bug and work on a fix.

Gurvan Kervern (gurvan22) wrote :

Same thing happens to me on a regular basis :

I have different OS on my computer and share the ~/.local/share/gtg folder between different distributions (Debian 7, Slackware 14, Mint (LMDE)). It can happen whether I open the same distribution twice in a row or if I open in another distributions.

I can't find a pattern, sometimes it happens, sometimes it doesn't.

The version for LMDE is 0.2.9. I'll update this post to give you the versions for Debian and Slackware later.

Nimit Shah (nimit-svnit) wrote :

Hi Gurvan,
    The current stable version of GTG is 0.3 and the bug has been
solved in that release. Moving on to 0.3 will solve your problem.

On 6/7/13, Gurvan Kervern <email address hidden> wrote:
> Same thing happens to me on a regular basis :
>
> I have different OS on my computer and share the ~/.local/share/gtg
> folder between different distributions (Debian 7, Slackware 14, Mint
> (LMDE)). It can happen whether I open the same distribution twice in a
> row or if I open in another distributions.
>
> I can't find a pattern, sometimes it happens, sometimes it doesn't.
>
> The version for LMDE is 0.2.9. I'll update this post to give you the
> versions for Debian and Slackware later.
>
> --
> You received this bug notification because you are subscribed to Getting
> Things GNOME!.
> Matching subscriptions: bugs
> https://bugs.launchpad.net/bugs/1038715
>
> Title:
> GTG unnests subtasks occasionally
>
> Status in Getting Things GNOME!:
> Fix Released
>
> Bug description:
> I'm using Getting Things Gnome! 0.2.9, which i received from the
> stable ppa. I'm running Ubuntu 12.04 LTS (Precise Pangolin)
>
> Sometimes, I'll launch GTG and the subtasks aren't attached to their
> parent tasks any longer. This is troublesome since I usually use
> parent/child relationships to break down large projects into smaller
> ones. When the child tasks aren't associated any longer, I can't
> figure out which project they relate to.
>
> I've been trying to isolate this to a specific action I'm taking, but
> can't seem to figure out what's triggering this. However, happens
> frequently for me. I would be happy to send you my gtg directory if
> you can't seem to reproduce.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gtg/+bug/1038715/+subscriptions
>

--
Nimit Shah,
B Tech 4th year,
Computer Engineering Department,
SVNIT Surat
www.dude-says.blogspot.com

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers