Give an option to remove tag color

Bug #1029342 reported by Nimit Shah on 2012-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Wishlist
kpytang

Bug Description

   Right now in GTG, we have an option to add a color to a tag but there is no option to remove the color.
   We can add white color but that does not remove the square box in front of the task_name in the browser (sorry I could not come up with the correct name).
   Maybe we can add a check in the editor such that, if a user selects white color for tag, the square thingy will be removed.

Related branches

Izidor Matušov (izidor) wrote :

You can remove a color by selecting the color the second time. (It removes the marker) If you don't know this little trick, it is hard to do that. IMHO, there should be an option to remove tag color.

Bertrand> What is your opinion on that?

Changed in gtg:
status: New → Incomplete
importance: Wishlist → High
milestone: none → 0.3

I agree it's a flaw. But this is the behavior of the default GNOME color picker, which will eventually land in GTG too. So I recommend sticking to this behavior anyway, as it promotes consistency. It should probably be discussed at GNOME level however.

Changed in gtg:
status: Incomplete → Won't Fix
Nimit Shah (nimit-svnit) wrote :

Is there some way to let the user know about this feature? So that he does not get irritated.

Izidor Matušov (izidor) wrote :

What about adding a redundant button to remove/reset color next to add a color? It will cost us a few pixels on screen but it'll solve the problem.

Lionel Dricot (ploum) on 2012-08-06
Changed in gtg:
milestone: 0.3 → 0.3.1
Izidor Matušov (izidor) wrote :

Bertrand> What do you say about adding an additional button? In this way, it would be better to have two different ways how to remove/reset color. Reopening, because I would like to discuss this problem.

Changed in gtg:
status: Won't Fix → Incomplete
milestone: 0.3.1 → 0.4
Nimit Shah (nimit-svnit) wrote :

We can either keep an additional button or keep white color to remove the tag color. As it is no one will select white as their background color. While trying to remove the background color, my first thought was white color was to be used to remove tag color

Izidor Matušov (izidor) on 2012-11-02
Changed in gtg:
status: Incomplete → Confirmed
importance: High → Low

For that one, we could add a button "Remove color" next to "Add custom color". It's probably the best solution.

Changed in gtg:
milestone: 0.4 → 0.3.1
tags: added: love
Izidor Matušov (izidor) on 2012-11-06
Changed in gtg:
milestone: 0.3.1 → 0.4
kpytang (kpytang) on 2013-10-24
tags: added: toreview
Nimit Shah (nimit-svnit) on 2013-10-24
tags: removed: toreview
Changed in gtg:
milestone: 0.4 → 0.3.1
assignee: nobody → kpytang (kpytang)
Nimit Shah (nimit-svnit) on 2013-10-24
Changed in gtg:
status: Confirmed → Fix Committed
Changed in gtg:
importance: Low → Wishlist
Nimit Shah (nimit-svnit) on 2013-11-25
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers