script_pocketmod doesn't have execute permission

Bug #1026400 reported by Matthew Kress on 2012-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Izidor Matušov

Bug Description

Getting Things GNOME! 0.2.9.r1206
Linux Mint 13

When trying to create a Foldable booklet (PDF) from the Export plugins I get a popup error "Document creation failed. Ensure you have all needed programs." after trying to save.

The command line shows:

/bin/sh: 1: /usr/share/gtg/GTG/plugins/export/export_templates/script_pocketmod: Permission denied

script_pocketmod permisions are -rw-r--r--

Proposed solution:

Pack script_pocketmod with execute permission.

Related branches

Izidor Matušov (izidor) on 2012-07-23
summary: - Foldable booklet (PDF) Export Doesn't work
+ script_pocketmod doesn't have execute permission
description: updated
Changed in gtg:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Izidor Matušov (izidor)
milestone: none → 0.3
Lionel Dricot (ploum) wrote :

This looks like a packaging bug. There's nothing that can be done at GTG's level. (feel free to reopen if we can do anything)

Changed in gtg:
status: Confirmed → Invalid
milestone: 0.3 → none
Izidor Matušov (izidor) wrote :

At least, we can fix it in GTG Daily PPA :) Or maybe read the first line of the script and run the script directly in that interpreter. It would solve the problem with the permission.

Changed in gtg:
status: Invalid → Confirmed
milestone: none → 0.3
Izidor Matušov (izidor) on 2012-08-11
Changed in gtg:
status: Confirmed → In Progress
Changed in gtg:
status: In Progress → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers