Numbers of tasks in tags pane disappear after a regular search

Bug #1026312 reported by Roquentin on 2012-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Unassigned

Bug Description

After performing a search for an expression (not a smart tag), the numbers shown on the right of each entry in the tags pane disappear.

The tags pane displays the numbers correctly after a smart tag search.

Related branches

description: updated
description: updated
description: updated
Nimit Shah (nimit-svnit) wrote :

which version of GTG are you using?
I am using GTG 0..2.9 rev 1206 and I am having trouble reproducing the bug.
Will you please provide some more information or maybe screenshots?

Changed in gtg:
status: New → Incomplete

It is rev. 1210. Yes it was pretty simple: the tags pane was not wide enough and the numbers could not be seen. Enlarging the pane shows solves the problem. I thought the menu was not updated.

This is not a serious issue, but one could put a scrollbar at the bottom. This would signal if there is missing information on the right as in my case.

The root of my problem is that the search entry indents all other entries because the small triangle icon appears on the left. This shifts the numbers out of the pane.

Izidor Matušov (izidor) on 2012-07-22
Changed in gtg:
status: Incomplete → Confirmed
importance: Undecided → Medium
milestone: none → 0.3
Izidor Matušov (izidor) wrote :

Bertrand> Do you remember why was the horizontal scrollbar in the tagsidebar disabled? I think it should be set to "automatic" to prevent bad experience like this. What is your opinion?

Nimit Shah (nimit-svnit) wrote :

Izidor we had discussed it for this bug: https://bugs.launchpad.net/gtg/+bug/970742
There you had said, that porting GTG to GTK 3.0 would solve the bug.

Izidor Matušov (izidor) wrote :

Nimit, you're right. (and my memory is quite forgetive) I would propose to add the horizontal scrollbar as a temporary workaround and after porting to GTK3 to solve it as proposed in bug #970742

Changed in gtg:
status: Confirmed → Fix Committed
Izidor Matušov (izidor) on 2012-11-02
Changed in gtg:
assignee: nobody → Antonio Roquentin (antonio-roquentin)
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers