Fail to load a config file

Bug #1020611 reported by Izidor Matušov on 2012-07-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Medium
Abhiram

Bug Description

Installed GTG in Ubuntu 10.04 - it worked fine for a week or two, then one day it wouldn't start. I started it via the terminal and got this message:
Traceback (most recent call last):
  File "/usr/bin/gtg", line 52, in <module>
    sys.exit(GTG.gtg.main(options, args))
  File "/usr/share/gtg/GTG/gtg.py", line 107, in main
    config = CoreConfig()
  File "/usr/share/gtg/GTG/core/__init__.py", line 86, in __init__
    self.conf_dict = ConfigObj(self.CONF_DIR + self.CONF_FILE)
  File "/usr/lib/pymodules/python2.6/configobj.py", line 1238, in __init__
    self._load(infile, configspec)
  File "/usr/lib/pymodules/python2.6/configobj.py", line 1328, in _load
    raise error
configobj.ConfigObjError: Parsing failed with several errors.
First error at line 3.

***********************************

GTG should in such a case load default configuration instead (i.e. fail back).

Related branches

Izidor Matušov (izidor) on 2012-07-03
Changed in gtg:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 0.3.2
tags: added: love
Abhiram (abhiram-ampabathina) wrote :

just revert the code base.
This would take back your changes to normal.

type "bzr revert" in terminal.

Data , code will be safe.

Abhiram (abhiram-ampabathina) wrote :

Hello izidor,

                               I have made the changes you told me to very earlier. its just that the code is not uploading. I have an error while uploading. But, the bug is fixed. Let me try making another account and clone and do it again.

Permission denied (publickey).
bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist.

This is the error while uploading. If you have any idea. please guide me.

Best,
Abhiram

Abhiram (abhiram-ampabathina) wrote :

Hello izidor,
                                 As of now, i am submitting a patch file to get things going. I will get the code uploaded very soon. I donno what is wrong here. Anyhow, i will create a new one and upload it again.

Best,
Abhiram

Abhiram (abhiram-ampabathina) wrote :

Hello izidor,
                                 As of now, i am submitting a patch file to get things going. I will get the code uploaded very soon. I donno what is wrong here. Anyhow, i will create a new one and upload it again.

Best,
Abhiram

Izidor Matušov (izidor) wrote :

Abhiram, sometimes Launchpad has intermittent problems with uploading files. Try it later. The patch you provided is not against GTG codebase at all. (There is no method isFull)

Changed in gtg:
status: Confirmed → In Progress
assignee: nobody → Abhiram (abhiram-ampabathina)
Izidor Matušov (izidor) on 2012-07-18
Changed in gtg:
milestone: 0.3.2 → 0.4
Abhiram (abhiram-ampabathina) wrote :

Hello izidor,
                                I have implemented in the way you said to implement long back. The reason is iam not able to upload it to launchpad. It once got uploaded nicely. But, now i am getting an error. I will try deleting my account and trying with another. Please tell me if you have any idea about this.

Best,
Abhiram

Abhiram (abhiram-ampabathina) wrote :

Hello izidor,
                                            When i try to upload the code i get this error.

ConnectionReset reading response for 'BzrDir.open_2.1', retrying
Permission denied (publickey).
bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist.

Where as i have the public key with me. I am struck here. Can you help me?

Best,

Abhiram

Izidor Matušov (izidor) on 2012-07-24
Changed in gtg:
assignee: nobody → Abhiram (abhiram-ampabathina)
Izidor Matušov (izidor) on 2012-07-24
Changed in gtg:
status: In Progress → Fix Committed
milestone: 0.4 → 0.3
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions