Saved searches can't be deleted when GTG crashes

Bug #1013869 reported by Izidor Matušov on 2012-06-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
High
Unassigned

Bug Description

Steps to reproduce:
  1, Search for something
  2, Restart GTG
  3, Delete a search
  4, Kill GTG with xkill
  5, Start GTG

Expected result:
  The search is deleted.

Actual result:
  The search is not deleted.

It is because tags.xml is saved only when quitting GTG properly. The similar case happens when GTG runs during rebooting.

Related branches

Changed in gtg:
assignee: nobody → Antonio Roquentin (antonio-roquentin)
Changed in gtg:
status: Triaged → In Progress

The second patch also fixes the companion bug: a smart search is not saved if gtg is xkilled. Probably there is a more elegant solution, but it works.

Izidor Matušov (izidor) wrote :

Antonio> could you create a merge request for your solution? You would get a commit in GTG :) (Useful for stats like https://www.ohloh.net/p/gtg :)

Changed in gtg:
status: In Progress → Fix Committed
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers