Notification area icon should change color when there are urgent tasks

Reported by Roquentin on 2012-05-17
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Getting Things GNOME!
Wishlist
Unassigned

Bug Description

I would like to suggest a slight enhancement to the notification area plugin. The notification icon could be colored differently according to whether there are urgent tasks to do or not.

Use case: I wake up in the morning and I want to know if there is anything urgent to do today. I could have a look at the notification area and see the icon colored if there are urgent tasks to do ("danger zone", see below). If the icon is white, I can relax and have my coffee without even opening the GTG main window. In the end, the purpose of the notification area is to notify people of events that require their attention, not simply to provide an extra launcher for the application.

The danger zone is defined as a time span in days. If number of days left to do a task are less than this time span, then the task is in danger zone. When there is at least one task in danger zone, the icon should be colored. Overdue tasks are of course always in danger zone.

Setting a danger zone of 0 days should disable the attention monitor and reproduce the old behavior.

The icon color should adhere to the current theme.

----
A previous specification of the icon coloring was:
- green if there are tasks due soon ("danger zone")
- red if there are tasks due today or overdue tasks
- white if there is nothing urgent to do

Related branches

Izidor Matušov (izidor) wrote :

I like the idea, although it won't be usable for me (always showing red or green). Wouldn't be better to have a separate plugin which on startup of GTG would provide information like that? Using a notification or open an extra window to show you important tasks to do in danger zone.

The question is if you want to be notified about being in a danger zone always (it might feel deprivating) or on startup.

I suppose it should take in account only doable tasks (tasks shown in workview) for computing danger zone.

Changed in gtg:
status: New → Incomplete
tags: added: love

Usage patterns may vary significantly, therefore I think the user should be allowed to define its own danger zone, very much like in the task urgency color plugin. One could even set the danger zone to zero and the icon would only turn colored when there is something really urgent. Or one could simply disable this feature and have it white all the time. I think two more settings in the plugin preferences should do the work.

For what is worth, here is my workflow. I usually have a danger zone of one day, since I want to know about tasks due tomorrow so as to get ready. Second, I need to know what tasks are due today (or are overdue). I am a lucky person and there are days where I have nothing urgent to do, although I may have many doable tasks (those in the workview). I just want to be visually and quickly reminded about urgent things (today or tomorrow).

Having this reminder only at startup wouldn't work well for me. The computer may be already open, for instance at work. On my laptop I have GTG in the startup applications launched as minimized and I could easily miss the notification... eventually I would open the GTG window to check. I think a persistent visual reminder is not bad. Suppose I leave my computer for a couple hours: when I am back I know there is still something to do at a glance.

I agree that having a red icon there all the time may be annoying. What about a less obstrusive color? For instance the same light blue used in the Ubuntu messaging menu?

And yes, only workable tasks would matter. But like I said it would be great to make the danger zone a flexible, use-defined time span and to be able to "reduce the noise" depending on the usage pattern. Incidentally, similar issues have been discussed for the messaging menu (chat and emails), see Bug #957922.

I started working on this in this branch lp:~antonio-roquentin/gtg/notification_colored_icon. For the moment it uses the red envelope icon when there are tasks due today or overdue. The basic functionality is there.

Izidor Matušov (izidor) wrote :

What about better integration with the Unity and having a single "attention needed state"? GTG could use the same blue color as other indicators. It would benefit the user (the concept of blue icon means "Look there, you have to do something") and would introduce a simpler pattern (only one special state instead of two).

What should be default value to put a task into the danger zone? I would suggest 1 day, i.e. the tasks which should be done today.

Changed in gtg:
status: Incomplete → In Progress
importance: Undecided → Wishlist
assignee: nobody → Antonio Roquentin (antonio-roquentin)

Actually at the moment there is only one state and I agree this is the cleanest solution. I thought it could make sense to notify if there are tasks that "appeared" today on top of ther overdue tasks (like new unread messages in thunderbird).

I agree to use the light blue color, see comment #2.

The current setting for the danger zone is 1 day.

> The current setting for the danger zone is 1 day.

... and of course I agree this is the most reasonable default. I will update the bug description when I have a moment.

I realized that GTG does not update start and due dates at midnight. It means if I leave GTG open overnight (e.g. session remains open or is suspended) the icon won't change color when I am back in the morning. I would need a signal that a new day has started. Would that be possible? I don't know how this should be handled...

Izidor Matušov (izidor) wrote :

Please, assume that tasks are refreshed at midnight / in the morning. It is already reported as the bug #514926. When you have a working prototype of your solution, I will implement regular refreshing of tasks.

description: updated

I feel the version in the linked branch is basically ready.

Known issue: temporarily I have added a colored icon in the plugin directory, which must be added it to the theme by hand. In my case I copied it as

/usr/share/icons/ubuntu-mono-dark/apps/16/gtg-need-attention.svg

and then did sudo gtk-update-icon-cache. There is still a slight shift in position every time the icon gets updated, I have no idea where it comes from :-(

tags: added: toreview
Changed in gtg:
status: In Progress → Fix Committed
tags: removed: toreview
Nimit Shah (nimit-svnit) on 2014-02-23
Changed in gtg:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers