The GStreamer Multimedia Framework

OpenOffice.org Impress: Faltering embedded sound in PPS files

Reported by Pablo Ruiz Múzquiz on 2008-11-15
66
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GStreamer
New
Undecided
Unassigned
gst-plugins-ugly
New
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

After testing this with three different PPS files, each one with an embedded soundfile, I can say this:

- Ubuntu 8.10 updated to 2008-11-15
- Tested with OSS-ALSA-PulseAudio
- Tested with OpenOffice 3.0 from PPA (just in case it was a 2.4 bug only)
- Tested with typical PPS files sent by email and consumed by mothers and grandmothers alike :-)

Ubuntu 8.10 (brand new install, no upgrade)
OpenOffice.org 1:2.4.1-11ubuntu2
Acer Aspire 5630 (two-year old pretty standard laptop)

I expected the sound to play flawlessly as slides went by.
Instead, the music/sound gets interrupted every 0.5 sec or so and continues to play after another 0.5 sec, giving the impression of a faltering sound. It's very annoying.

Same PPS file works as expected using:

Ubuntu 8.04.1
OpenOffice.org 1:2.4.1-1ubuntu2

though it's worth mentioning that it was tested on a different machine with "Autodetect" in sound preferences.

Luke Yelavich (themuso) wrote :

After doing some testing with the pps file attached to this bug, I've found the following:

OpenOffice.org appears to be linked against gstreamer, presumably for audio and other multimedia output. However, when attempting to set the audio output to either oss or pulseaudio in sound preferences, and examining the device nodes used in a terminal while openoffice plays the audio from a pps, it doesn't appear that openoffice uses /dev/dsp when oss is selected. In the case of pulseaudio, openoffice still plays audio if pulseaudio is running, and pulseaudio is chosen in sound preferences.

While this doesn't help solve the stutter, it does indicate that openoffice doesn't seem to be respecting the sound preferences settings. In addition, I'm enclined to believe that this is not an audio infrastructure problem. It has something to do with the way openoffice is working with gstreamer.

This was all tested on ubuntu 8.10, with OpenOffice 2.4.

So, anyone following this issue? Should it be considered upstream? It might be considered a minor bug but sooo many people use the computer for email, google and... opening pps from friends, and Ubuntu is partly aimed towards them, that I suggest nailing it down.

After nearly two months, the problem persists. Just in case it's of some help, the MS PowerPoint viewer will make a weird 8bit-like sound.

It has been tested with latest updated from 8.10 & OO.org 2.4 and I can't find any progress at all. Is there any further testing needed that could help devs?

I consider this bug to be a stopper for many eeepc-like users... which Ubuntu have as part of its wider audience.

I attach another file for testing purposes.

Chris Cheney (ccheney) on 2009-01-05
Changed in openoffice.org:
importance: Undecided → Medium
status: New → Confirmed

I know this mightn't be very useful but I tried both pps files on a 9.04 (2009-01-10) and OO.org 3.0m9 and everything worked as expected. It wasn't tested on the same machine, though, but on a Dell mini 9 netbook.

Chris Cheney (ccheney) wrote :

Do you still have this problem with the new version of OOo in the ppa at https://launchpad.net/~openoffice-pkgs/+archive ?

Changed in openoffice.org:
importance: Medium → Undecided
status: Confirmed → Incomplete

I experienced the same problem with OOo 3.0 from ppa a couple of months ago, but I'll check again.

pirrax (rpsutanto-googlemail) wrote :

I can confirm this problem. Ubuntu 8.10 Open Office 2.4. It's quite anoying, if the sounds stutter all the time during the presentation.

Ubuntu 8.10 w/ latest updates + OO.org 3.0.1rc1 300m14 build 9376 experiences the same problem. This is quite frustrating, to be honest. There are far more complex apps using sound than OO playing a background mp3 without issues.

Please let me know if I can perform any more tests (debugging for pro-users or even recipes for compiling or installing OOo from other non-ubuntu repositories).

Problem persists no matter if you use OOo 2.4 or OOo 3.0rc1

Changed in openoffice.org:
status: Incomplete → Confirmed
Chris Cheney (ccheney) wrote :

Hmm so either something in Jaunty or in the official OpenOffice.org 3.0m9 fixed the problem for you. Once Jaunty alpha 3 comes out later this week could you test with that to see if it helps fix the problem for you? If it does then it was something outside of OpenOffice.org in Jaunty that fixed the issue otherwise it may be something wrong with a go-oo patch.

Thanks,

Chris Cheney

So the thing is:

8.04 up-to-date + OOo 2.4 will work
8.10 up-to-date + [ OOo 2.4 | latest OOo from ppa won't work ]
9.04 alpha2 up-to-date + latest OOo from jaunty repo will work

Yes, I'll try with alpha3 this week (or just update packages on my 9.04 installation I guess) and post here.

Chris Cheney (ccheney) wrote :

Luke,

Pablo's comment that 8.10 won't work even with the OOo 3.x from the ppa but it works fine on 9.04 makes me think this isn't something wrong with OOo but with the audio stack in 8.10...

Any ideas?

Chris

Chris Cheney (ccheney) wrote :

Sorry for bouncing this bug around, Pablo commented above that OOo which works on 9.04 won't work on 8.10 properly for audio. This really seems like some sort of weirdness in 8.10, but I may be wrong... Feel free to bounce back. :-)

Maybe we should try to find similar bugs regarding audio subsystem affecting other apps.
(also don't forget that 8.04 + OO[2.4|3.0] works fine)

Any feasible way to backport 9.04 audio subsystem into 8.10 and see what happens?

Daniel T Chen (crimsun) wrote :

Pablo, are you confirming that using ALSA instead of PulseAudio (i.e., pulseaudio -k and then starting OO) eliminates the symptom on current 8.04?

Not at all. 8.04 works fine out-of-the-box.
The problem arises with 8.10 only.

BTW, pulseaudio -k and restart OO in 8.10 won't fix the problem.

pvdeynse (vandeynse) wrote :

Have same problem, with Ubuntu 8.10 and pulseaudio 0.9.10-2ubuntu9.2

Looking through the releases of pulseaudio I see the following :
   "what's up next with PulseAudio's new glitch-free playback model" and this starting with pulseaudio 0.9.11

I didn't find any update for Ubuntu 8.10
can someone make the latest version of pulsaudio (0.9.14) available for Ubuntu 8.10 to test if this solves the problem, or do we have to wait for Ubuntu 9.04

That sounds like a good idea. I will definitely test pulseaudio >0.9.10 if someone provides a reliable repository for 8.10. I hope we don't have to wait until 9.04 to get thsis fixed (sounds too much like, you know,...)

Daniel T Chen (crimsun) wrote :

Please try modifying the line in /etc/pulse/default.pa to read:

load-module module-hal-detect tsched=0

Changed in pulseaudio:
importance: Undecided → Low

I did that and the problem is still there.

I went to System->Preferences->Sound to play with config and while trying to force Autodetect to Pulseaudio sound server I got a "server refuses to connect" type of message.

I did /etc/init.d/pulseaudio restart and it went silently

I then typed "pulseaudio" as is and got this:

elfo@fornost:~$ pulseaudio
W: ltdl-bind-now.c: Failed to find original dlopen loader.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operación no permitida
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operación no permitida
E: module-hal-detect.c: Failed to parse module arguments
E: module.c: Failed to load module "module-hal-detect" (argument: "tsched=0"): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.

I can assure that my line in default.pa reads exactly as you said.

pvdeynse (vandeynse) wrote :

Sorry but I couldn't wait, I've upgraded my Ubuntu 8.10 to 9.40 and now everything is working like a charm
I still believe pulsaudio 0.9.10 is the bad guy within Ubuntu 8.10 with Ubuntu 9.40 we are using 0.9.14-0ubuntu1

martincasc (martincasco) wrote :

Hello...

I have Ubuntu 8.04.2 and OOO 3.0, everything is update properly but I'm still couldn't see PPS files properly.

Sometimes Power Point Viewer freez, but never play the sound files embedded on PPS files.

Also downloaded Microsoft Power Point Viewer and installed with Wine. This, sometimes freez and sometimes play audio but doesn't here very good...

If I use Impress I have to press F5 every time I want to see a PPs file, doesn't matter if the file is on my hard disc or I tray using Firefox when I'm checking my mails, I always have to press F5, but the sound doesn't play too.

So, Sometimes I can see my PPS files, But never play the sound attached with de pps.

I don't know way Ubuntu doesn't have a native PPS Viewer instead using Power Point viewer. It seems use Wine for it.

Regards!

David Oxland (doxland) wrote :

Situation the same for me.
Pulseaudio was killed before start.

Daniel T Chen (crimsun) on 2009-02-14
Changed in pulseaudio:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu6

---------------
pulseaudio (0.9.14-0ubuntu6) jaunty; urgency=low

  * 0004_disable_autospawn.patch: Disable this patch. Doing so
    allows the daemon to spawn if not already running, which
    works around LP: #191027, #204272
  * 0012_clarify_driver_error_redirect_to_alsa_devs.patch:
    - Only log POLL* being set if tsched is used so that syslog
      isn't filled with innocuous messages when we set tsched=0
      (see 0030 below) (LP: #323712),
    - Hint 'linux' source package instead of 'alsa-driver' for
      Launchpad bug reports,
    - The debug-specific portion is only applicable to 0.9.14;
      0.9.15 enables a rate limiting module by default to work
      around this (and other) issues
  * 0029_fix_suspend_on_idle_null_race.patch: Handle sink case,
    too
  * 0030_set_tsched0.patch: Work around a shedload of (driver)
    bugs by falling back to interrupt-based buffer semantics
    (LP: #190754, #292880, #295519, #298494, #301755, #302964,
     LP: #319118, #323976, #324103, #326205, #326864)
  * Backport fixes from git HEAD:
    - 0031_fix_6chan_map.patch,
    - 0032_reinit_proplist.patch,
    - 0033_fix_pa-gcc-packedmalloc.patch,
    - 0034_bt_fixes.patch
  * Make invoking the stop target in the initscript not fail an
    upgrade (LP: #317921)
  * Previous upload (0.9.14-0ubuntu3) fixed LP: #321357
  * 01PulseAudio: use sudo -H to ensure that $HOME is, in fact,
    the user's when invoking pacmd for suspend/resume

 -- Daniel T Chen <email address hidden> Sun, 15 Feb 2009 02:35:26 -0500

Changed in pulseaudio:
status: Fix Committed → Fix Released

Just for clarification. What bug was actually fixed? the one that prevented pulseaudio daemon from starting or the faltering sound in pps files?

Thanks,
Pablo

PsYcHoK9 (psychok9) wrote :

I can't understand the Ubuntu policy:
I've this bug, and for fix a bug, i need to wait April or use a Alpha version of all Ubuntu? I can't download only the fix/application-pulse fixed?
Very annoying...

Chris Cheney (ccheney) on 2009-02-21
Changed in openoffice.org:
status: New → Fix Released

I have exactly the same problem here on a fresh installation of ubuntu 8.10 without any changes and different power point files. This sound-on sound-off sound-on is really anoying

Why do the ubuntu developers not upload this pulseaudio bug fix to the Intrepid repositories???

T_B (tfromb) wrote :

Same issue here, did cost me hours to finally found out there is (still) no cure...

gudwin (gudwin) wrote :

Just an interesting remark ... if you go to ~/.openoffice.org2/user/gallery and try to open anyone of the .wav files which were showing the problem in impress, and now try to open it with totem, or any other gstreamer application, the same problem will appear. So it seems that the problem is related, first, to the .wav files (which in fact are mp3 files), and on how gstreamer tries to play it.

gudwin (gudwin) wrote :

And a complement ... if you try to open these files in xine, they play without any problem. The problem manifest itself only using gstreamer-based applications.

YannUbuntu (yannubuntu) wrote :

Dear all,
here is something found by the French Team: Gstreamer0.10-plugins-ugly may be in cause.
For example, I use Ubuntu 8.10, OOo 2.4.1, and I have the bug with the current version (0.10.9) of Gstreamer0.10-plugins-ugly.
But if I install the version 0.10.6 of Gstreamer0.10-plugins-ugly instead of the 0.10.9, the bug disappears.

I put the 0.10.6 version as an Attachment if you want to test it (don't forget to block the version in Synaptic). If you confirm, it might become a patch for Intrepid.

Regards

gudwin (gudwin) wrote :

It worked for me ! In fact it was easier than that ... I just uninstalled (using synaptic) the gstreamer0.10-plugins-ugly package, which used the 0.10.9-1ubuntu0.1 version, and installed the gstreamer0.10-plugins-ugly-multiverse, which uses a variant 0.10.7-2 version that doesn't exhibit the problem. You need to have the multiverse repository enabled in synaptic/adept.
Many thanks ! I think this issue is solved !

Anthony Borrow (arborrow) wrote :

Gudwin - I uninstalled the gstreamer0.10-plugins-ugly package and reinstalled gstreamer0.10-plugins-ugly-multiverse and from what I can tell all is working well. Thanks for the tip! Peace - Anthony

YannUbuntu (yannubuntu) wrote :

FYI I have both Gstreamer0.10-plugins-ugly 0.10.6 and gstreamer0.10-plugins-ugly-multiverse 0.10.7-2.
So I guess that Gstreamer0.10-plugins-ugly brings functionnalities that gstreamer0.10-plugins-ugly-multiverse doesn't bring.
For example, a French user said he couldn't read .MPC files in Rythmbox any more after uninstalling Gstreamer0.10-plugins-ugly. Another could not read .WMA files any more...

So the solution of this bug is not to uninstall Gstreamer0.10-plugins-ugly, but to find which version(s) of Gstreamer0.10-plugins-ugly bring the bug.

For the moment,
Gstreamer0.10-plugins-ugly 0.10.9 (current version) is not ok (BUG)
Gstreamer0.10-plugins-ugly 0.10.6 is ok. (NO BUG).

We should ask the owner of Gstreamer0.10-plugins-ugly to check which modifications have been brought since 0.10.6. Does anyone know how to contact him?

YannUbuntu (yannubuntu) wrote :

Update: version 0.10.8 looks to be ok also (worked for me and 1more people, now waiting for other people confirmation). Please find it in attachment.

Gstreamer0.10-plugins-ugly 0.10.9 (current version) is not ok (BUG)
Gstreamer0.10-plugins-ugly 0.10.8 is ok. (NO BUG).
Gstreamer0.10-plugins-ugly 0.10.6 is ok. (NO BUG).

I found the email adress of Gstreamer0.10-plugins-ugly owner ("Maintainers of GStreamer packages") via Gdebi. I will ask him to have a look at this page.

Couldn't try. I'm using x32_64. :-(

T_B (tfromb) wrote :

Just installed Gstreamer0.10-plugins-ugly 0.10.8 and it works fine. Thanks for everyone trying to solve this and posting the solution.

Jose (jribeiro-pobox) wrote :

Tried to install Gstreamer0.10-plugins-ugly 0.10.8 and got message Dependency is not satisfiable: libmad0. BTW, libmad0 (0.15.1b-2) is installed according to Synaptic.

T_B (tfromb) wrote :

Hi Jose, did you uninstall 0.10.9 before trying to install 0.10.8?

gudwin (gudwin) wrote :

Another possible solution to this bug, if you don't want to uninstall 0.10.9 and install 0.10.8 is to leave 0.10.9 installed, install plugins-ugly-multiverse and then as su go to
/usr/lib/gstreamer-0.10 and change the name (e.g. to libgstmpegaudioparse.so.notworking) or delete the file

libgstmpegaudioparse.so

where the problem seems to be. Looking within the packages, I could see that the plugins-ugly is basically a compilation of the following set of audio and video codecs:

/usr/lib/gstreamer-0.10/libgsta52dec.so
/usr/lib/gstreamer-0.10/libgstasf.so
/usr/lib/gstreamer-0.10/libgstcdio.so
/usr/lib/gstreamer-0.10/libgstdvdlpcmdec.so
/usr/lib/gstreamer-0.10/libgstdvdread.so
/usr/lib/gstreamer-0.10/libgstdvdsub.so
/usr/lib/gstreamer-0.10/libgstiec958.so
/usr/lib/gstreamer-0.10/libgstmad.so
/usr/lib/gstreamer-0.10/libgstmpeg2dec.so
/usr/lib/gstreamer-0.10/libgstmpegaudioparse.so
/usr/lib/gstreamer-0.10/libgstmpegstream.so
/usr/lib/gstreamer-0.10/libgstrmdemux.so
/usr/lib/gstreamer-0.10/libgstsid.so

The plugins-ugly-multiverse, on the contrary, seems to be only

/usr/lib/gstreamer-0.10/libgstlame.so

or, in other words, the lame codec ....
so it is really not a full replacement for plugins-ugly.

Deleting the libgstmpegaudioparse.so, you will not be able to use the standard mpeg codec to play mpeg audio files, what should not be a problem as it is definitively broken. The libgstlame.so will provide an alternative codec to play mpeg audio files instead, so everything should work ok. At least, for me it is working. The other codecs provided by plugins-ugly should not be affected (can someone confirm that ?). It is not a definitive solution, but it will solve the main problem in the meantime, while the plugins-ugly package maintainers do not give a final solution to this bug.

Jose (jribeiro-pobox) wrote :

gudwin solution didn't work for me
latest versions in my Synaptics manager are 0.10.7-3 for ugly and 0.10.7-1 for multiverse (using Ubuntu 8.04)
how do I get 0.10.9 or 0.10.8?
thanks again

YannUbuntu (yannubuntu) wrote :

Hi Jose, thank you for your feedback.
This bug was initially reported for Ubuntu 8.10, so the solutions we gave were for 8.10.

I think you are the first one to report the bug under Ubuntu 8.04.
Do you confirm that you have the bug on ubuntu 8.04 with Gstreamer0.10-plugins-ugly_0.10.7-3 ?
Can someoneelse also confirm the bug on Ubuntu Hardy?
Regards

Jose (jribeiro-pobox) wrote :

Hi YannUbuntu,

Yes I do have the bug on Ubuntu 8.04 with gstreamer ugly 0.10.7-3.

José

YannUbuntu (yannubuntu) wrote :

For AMD64 users, it seems that the solution is to install the 0.10.6 version from Hardy:
http://fr.archive.ubuntu.com/ubuntu/pool/universe/g/gst-plugins-ugly0.10/gstreamer0.10-plugins-ugly_0.10.6-0ubuntu2_amd64.deb

YannUbuntu (yannubuntu) wrote :

FYI, I don't have this bug any more with Ubuntu 9.10 Karmic (gstreamer0.10.9-1).

Yes, I can't see it in 9.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers