pulseeffects: plugins not found after upgrading to 4.8.0-1

Bug #1896191 reported by Andrea Righi
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gst-plugins-bad
New
Undecided
Unassigned
pulseeffects (Ubuntu)
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

I'm getting the following warnings when I start pulseeffects and all the effects are grayed out:

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.971: limiter plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.971: compressor plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.972: filter plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.972: equalizer plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.972: reverb plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.972: bass_enhancer plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.973: exciter plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.973: crossfeed plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.973: maximizer plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.973: multiband_compressor plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.973: loudness plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.974: gate plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.974: pitch plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.974: multiband_gate plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.974: deesser plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.975: stereo_tools plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.982: delay plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.991: limiter plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.991: compressor plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.991: filter plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.992: equalizer plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.992: reverb plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.992: gate plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.993: deesser plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.993: pitch plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.993: webrtc plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.993: multiband_compressor plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.994: multiband_gate plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.994: stereo_tools plugin was not found!

(pulseeffects:6144): pulseeffects-WARNING **: 09:54:06.994: maximizer plugin was not found!

Before last update (groovy) everything was working fine.

Revision history for this message
Andrea Righi (arighi) wrote :

Looking at the apt logs it seems that yesterday the package libgstreamer-plugins-bad1.0-0 has been updated from 1.16.2-2.3ubuntu1 to 1.16.2-2.3ubuntu2. I don't see how, but maybe it's related to this problem... I'll investigate more.

Andrea Righi (arighi)
summary: - pulseeffects: missing plugins not found after upgrading to 4.8.0-1
+ pulseeffects: plugins not found after upgrading to 4.8.0-1
Revision history for this message
Andrea Righi (arighi) wrote :
Revision history for this message
Andrea Righi (arighi) wrote :

Quick update: if I recompile libgstreamer-plugins-bad1.0-0 on my box and install the debs generated on my box everything is working fine! So I guess there's something wrong in the stock libgstreamer-plugins-bad1.0-0 debs (or something is busted in my environment). I will investigate more to see exactly what is really happening.

Revision history for this message
Andrea Righi (arighi) wrote :

It seems that libgstreamer-plugins-bad1.0 has been recompiled against gstreamer 1.17 for some reasons.

I've recompiled the package in this ppa [1] (no changes, just a rebuild) and everything seems to work fine.

[1] https://launchpad.net/~arighi/+archive/ubuntu/pulseeffects

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseeffects (Ubuntu):
status: New → Confirmed
Revision history for this message
Andrea Righi (arighi) wrote :

This problem seems to be fixed with the new version of libgstreamer (1.18). I think we can close this bug now.

Changed in pulseeffects (Ubuntu Groovy):
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.