Can't install in Fedora 16

Bug #908500 reported by KitchM on 2011-12-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Grub Customizer
Medium
Daniel Richter

Bug Description

There were two sets of instructions given; the ones at the web site and the ones that came with the download. I cannot tell for sure what the problem is, but either way there were way too many errors to install the program. Missing components, unreadable files/directories, confusing commands, etc..

Maybe a new list of instructions would help. Otherwise I have no idea.

Thanks.

The problem is, that fedora uses other package names than debian/ubuntu, but the FAQ only contains the names of the debian packages. These packages are required to compile it using fedora:

gtkmm24-devel
gcc-c++
cmake
openssl-devel

This lets you compile grub-customizer, but there's another problem: fedora has different pathes (configuration directories, system command names), so Grub Customizer says there's no bootloader. I did some changes in 2.5 to let you set these settings.

If you want to try it before I've released 2.5, feel free to use the 2.5 branch (after installing the "bzr" package):

bzr branch lp:grub-customizer/2.5

then compile as usual:
sudo yum install gtkmm24-devel gcc-c++ cmake openssl-devel
cd 2.5
cmake .
make
sudo make install

and place this file to /etc/grub-customizer/grub.cfg:

MKCONFIG_CMD=grub2-mkconfig
UPDATE_CMD=grub2-mkconfig -o /boot/grub2/grub.cfg
INSTALL_CMD=grub2-install
CFG_DIR=/etc/grub.d
OUTPUT_DIR=/boot/grub2
OUTPUT_FILE=/boot/grub2/grub.cfg
SETTINGS_FILE=/etc/default/grub

(I should add an fedora section to my FAQ entry…)

Changed in grub-customizer:
status: New → Confirmed
assignee: nobody → Daniel Richter (danielrichter2007)
importance: Undecided → Medium

I forgot to say, the directory /etc/grub-customizer doesn't exist. You have to create it. If it doesn't exist, Grub Customizer uses its builtin commands.

Grub Customizer 2.5 is released now

Changed in grub-customizer:
status: Confirmed → Fix Released
KitchM (tech-frontrowcomputer) wrote :

Tried with new version. Here is output of make:
[ 2%] Building CXX object CMakeFiles/grub-customizer.dir/src/view/grublistCfgDlgGtk.cpp.o
In file included from /home/mpk/Downloads/grub-customizer_2.5/src/view/grublistCfgDlgGtk.cpp:19:0:
/home/mpk/Downloads/grub-customizer_2.5/src/view/grublistCfgDlgGtk.h:21:19: fatal error: gtkmm.h: No such file or directory
compilation terminated.
make[2]: *** [CMakeFiles/grub-customizer.dir/src/view/grublistCfgDlgGtk.cpp.o] Error 1
make[1]: *** [CMakeFiles/grub-customizer.dir/all] Error 2
make: *** [all] Error 2

Created /etc/grub-customizer, but did not help.

The message tells you, that there's no gtkmm.

Did you do `sudo yum install gtkmm24-devel`?

The file /etc/grub-customizer/grub.cfg is required after installation. Compiling should work anyway.

KitchM (tech-frontrowcomputer) wrote :

My mistake. I thought it was installed. Got it put in and then the process completed.

However, I could not find the program in the menus, so I tried the other method and got a prompt:
mpk@Verne grub-customizer_2.5$ 'gksu grub-customizer` / `sudo grub-customizer`
>

Weird.

KitchM (tech-frontrowcomputer) wrote :

There is a /etc/grub2.cfg, but no /etc/grub-customizer/grub.cfg.

Command line usage shows:
mpk@Verne grub-customizer_2.5$ grub-customizer
The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.

That is the latest results.

'gksu grub-customizer` / `sudo grub-customizer` are two possible commands.

gksu grub-customizer
sudo grub-customizer

AFAIK gksu is not available in fedora, but you should be able to run Grub Customizer simply by running `grub-customizer`.

Anyway, there should be an entry for Grub Customizer on the menu. AFAIK it was Applications -> Other.

As I mentioned before, the file /etc/grub-customizer/grub.cfg has to be created. Grub Customizer will find it and use this config instead of the built-in one.

> The value for the SHELL variable was not found the /etc/shells file

I don't know why you get this problem, I didn't ever got such a message… maybe it works if you run Grub Customizer this way:

declare -x SHELL="/bin/bash"
grub-customizer

KitchM (tech-frontrowcomputer) wrote :

It turned up under Administration > Grub Customizer.

But it still won't run.

What about:

declare -x SHELL="/bin/bash"
grub-customizer

?

KitchM (tech-frontrowcomputer) wrote :

Got the same thing as in #7 above.

Does it work when using

sudo grub-customizer

?

KitchM (tech-frontrowcomputer) wrote :

Command not found.

oh you're right. You have to give the full path in this case:

sudo /usr/local/bin/grub-customizer

KitchM (tech-frontrowcomputer) wrote :

That worked!

I then got a window popup that stated:
No Bootloader found.
Do you want to select another boot partition?

At this point I tried but there was no appropriate choice.

I may be wrong (I'm just changing to Fedora 16), but the install created an LVM setup for the drive. For some reason, the regular sda1 partitions are not visible. Most things are seen on sda3, which does not sound right.

Also, I am guessing, but I believe I understand Fedora 16 to use GRUB2.

That's all I've got so far.

(At least we know how to install and start it!!!!)

Ok. The difference is that Grub Customizer runs directly as root. The alternative way is that it creates a root instance by running `pkexec [...]/grub-customizer`

The error now means that Grub Customizer didn't find the specified pathes. Please check the debug output starting with "checking for". Ignore the BURG checks (this is an alternative bootloader) but look for the parts of grub. If there aren't errors but messages like "not found", you have to configure the file /etc/grub-customizer/grub.cfg properly.

Yes, fedora 16 uses Grub2 as default.

KitchM (tech-frontrowcomputer) wrote :

And how do I find the debug log errors?

There's no log file. Look at the terminal output of Grub Customizer.

KitchM (tech-frontrowcomputer) wrote :

Do you mean that I should start it in a terminal?

I thought you already do so (because of sudo)...

KitchM (tech-frontrowcomputer) wrote :

*** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
     [running on an installed system]
sh: hwinfo: command not found
     [checking the burg-mkconfig command… ]
     [not found]
     [checking the grub-mkconfig command… ]
     [not found]

It looks for grub-mkconfig... there's something wrong with your /etc/grub-customizer/grub.cfg

Please make sure the file contains the content I posted above!

KitchM (tech-frontrowcomputer) wrote :

Sorry for being a little dense. I created the grub.cfg file in /etc/grub-customizer/ with the following:
 MKCONFIG_CMD=grub2-mkconfig
 UPDATE_CMD=grub2-mkconfig -o /boot/grub2/grub.cfg
 INSTALL_CMD=grub2-install
 CFG_DIR=/etc/grub.d
 OUTPUT_DIR=/boot/grub2
 OUTPUT_FILE=/boot/grub2/grub.cfg
 SETTINGS_FILE=/etc/default/grub

I ran /usr/local/bin/grub-customizer as root and got:

(grub-customizer:2456): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(grub-customizer:2456): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(grub-customizer:2456): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
 *** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
     [running on an installed system]
     [checking the burg-mkconfig command… ]
sh: hwinfo: command not found
     [not found]
     [using custom Grub2 configuration]
     [checking the command… ]
     [not found]

KitchM (tech-frontrowcomputer) wrote :

I reran the command as non-root:
*** initializing (w/o specified bootloader type)…
   * reading partition info…
   * Loading Framebuffer resolutions (background process)
   * Finding out if this is a live CD
     [running on an installed system]
     [checking the burg-mkconfig command… ]
sh: hwinfo: command not found
     [not found]
     [using custom Grub2 configuration]
     [checking the command… ]
     [not found]

KitchM (tech-frontrowcomputer) wrote :

There is no /boot/grub/grub.cfg, but there is a /boot/grub2/grub.cfg.

Should I edit the grub.cfg in the /grub2 directory instead?

Is there a space before MKCONFIG_CMD and before the other options? This may be the problem. Please remove the spaces!

KitchM (tech-frontrowcomputer) wrote :

Yes, there was. So I edited the file, removed them and re-saved it. Then I started it up again by using /usr/local/bin/grub-customizer.

Great news! It worked.!!!!! Absolutely awesome!!

Thanks for your help. You should now have the necessary steps to create the install directions for Fedora 16. I look forward to reading them

I will be trying the program out and will see what it can do.

Thanks much.

Thank you for the customizer and all the info above that helped to get it to work.
We really need it.
I am using it on Fedora 16. It is on the menu under administration, but I need to start it from a
terminal as root. I now have the menu entries in the order I want.
I did not get a background picture to work yet. Will any picture in any folder work?
Thanks

Do you get it working when following this way: https://kororaa.org/forums/viewtopic.php?f=11&t=258

… or do you know another way of doing it?

Yes.
Doing this adds a background:

Then add the following to /etc/default/grub
Code: Select all
    GRUB_GFXMODE=1280X1024x16
    GRUB_GFXPAYLOAD_LINUX=keep
    GRUB_TERMINAL=gfxterm
    GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/normalish/verne.png

Save the file and run
Code: Select all
    sudo grub2-mkconfig -o /boot/grub2/grub.cfg

I will try it with a different .png picture.
Also will see if I can use a larger font size.
It would have been nice if I could do the background with Grub Customizer,
but looks like this will work.

Ah ok, now it works for me too.

I reduced the settings to

GRUB_GFXMODE=1280X1024x16
GRUB_BACKGROUND=/usr/share/backgrounds/verne/default/normalish/verne.png

After doing

sudo grub2-mkfont --output=/boot/grub2/unicode.pf2 /usr/share/fonts/dejavu/DejaVuSansMono.ttf
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

everything is fine.

The Problem why it doesn't work when using Grub Customizer is that on Debian systems I have to create a /usr/share/desktop-base/grub_background.sh which sets these options. This file is loaded from the 05_debian_theme script which doesn't exist on fedora. So I think the best way is to check whether the script 05_debian_theme exists and otherwise to set the properties as options instead of writing the grub_background.sh.

Also I have to check whether the font file exists and otherwise to execute grub2-mkfont.

I fixed the wallpaper/color issue (release 2.5.1)

The other problem (unstartable from the menu) didn't appear on my fresh installed Fedora 16. Is policykit up to date on your system? It must be 0.102 or larger. Try running it from the command line as (non root). What's the error message?

As far as I know my system is up to date.
I do not know about policykit. I have selinux disabled now. It was permissive before.
Here is what I get when running it as non root:

[rog@Asrockfc Documents]$ /usr/local/bin/grub-customizer
The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.

Do I need to uninstall 2.5 before installing your new version?

I have polkit-desktop-policy 0.102-3.FC16

Hmm the same problem like KitchM had…

Can you try to find out the conditions under which the problem occur - by using a fresh installation of fedora (VirtualBox…)?

Oh I forgot to say that you don't have to uninstall 2.5 before.

Here is the complete error when running customizer as non root (copied from a log file):

COMMAND=/usr/bin/gedit /var/log/secure

Jan 7 11:34:15 Asrockfc pkexec[1970]: rog: The value for the SHELL variable was not found the /etc/shells file [USER=root] [TTY=/dev/pts/1] [CWD=/home/rog/Documents] [COMMAND=/usr/local/bin/grub-customizer no-fork]

When I installed your program I was logged in as root rather than using sudo.
I have never used virtualbox. It would take me a while to learn how to use it.

Hmm ok, then do the following and tell me what's the output of each command:

pkexec echo "OK"
echo $SHELL
cat /etc/shells
SHELL=/bin/bash grub-customizer

Here it is:

[rog@Asrockfc Documents]$ sudo pkexec echo "OK"
The value for the SHELL variable was not found the /etc/shells file

This incident has been reported.
[rog@Asrockfc Documents]$ sudo echo $SHELL
/bin/bash
[rog@Asrockfc Documents]$ sudo cat /etc/shells
/sbin/nologin
/bin/dash
/bin/zsh
[rog@Asrockfc Documents]$ sudo SHELL=/bin/bash grub-customizer
sudo: grub-customizer: command not found

Nice work. Thanks
I used this fix: su -c 'yum reinstall bash'
Now I can start Grub Customizer from the menu or a Launcher
on the desktop as non root.
Then it asks me for a password as expected.
Thank you

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers