Grub Customizer - a graphical grub2 settings manager

Grub Customizer & Grub 1.99 Images, Fonts & Submenus

Reported by drs305 on 2011-05-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Grub Customizer
High
Daniel Richter

Bug Description

The introduction of Grub 1.99 causes a few issues with Grub Customizer
1. The Grub 1.99 submenu feature changes the way an item in a submenu is designated in /etc/default/grub's GRUB_DEFAULT setting. Specifically, a title entry in a submenu must include either the submenu title or a numerical entry prior to the title.
Example: GRUB_DEFAULT="1,Ubuntu, with Linux 2.6.38-7-generic"

2. Grub 1.99 allows an image in /boot/grub to be automatically used if GRUB_BACKGROUND is not in /etc/default/grub.
Since GC uses "GRUB_MENU_PICTURE", Grub 1.99 finds the image in /boot/grub before it will use "GRUB_MENU_PICTURE".

3. Several users, verified by me, say the font color selector isn't working in GC with 1.99.

I've detailed some of these issues in the following Ubuntu Forum thread:
http://ubuntuforums.org/showthread.php?t=1664134

Daniel, again, thanks for your work with GC. I have lots of forumites praising your efforts almost every day.

drs305 (drs305) wrote :

Correction:
menu_color and menu_color highlight probably work correctly with Grub 1.99.

A user request is that "menu_color_normal" and "menu_color_highlight" be added as options (not a bug).

drs305 (drs305) wrote :

Correction again:
color_normal and color_highlight probably work correctly.

Users are requesting an entry for menu_color_normal and menu_color_highlight

Changed in grub-customizer:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Daniel Richter (danielrichter2007)
milestone: none → 2.1.3

On Thu, 2011-05-12 at 16:15 +0000, Daniel Richter wrote:
> ** Changed in: grub-customizer
> Status: New => In Progress
>
> ** Changed in: grub-customizer
> Importance: Undecided => High
>
> ** Changed in: grub-customizer
> Assignee: (unassigned) => Daniel Richter (danielrichter2007)
>
> ** Changed in: grub-customizer
> Milestone: None => 2.1.3
>

Daniel,

I actually have another typo in the bug report. A submenu menuentry
title example would be
GRUB_DEFAULT="2>Ubuntu, with Linux 2.6.38-7-generic"
or
GRUB_DEFAULT="Previous Linux versions>Ubuntu, with Linux
2.6.38-7-generic"

If you haven't experienced the Grub 1.99 submenus:
http://ubuntuforums.org/showthread.php?p=10720316

Dave

Yes, I noticed the typo (wondered, how grub2 should separate the "," as delimiter in opposite to the "," inside the title ;-) ).

The submenu feature seems to be much work as I have to:
 * detect it while parsing; parsing the second layers
 * build the tree inside the entry list
   * but the user should still be able to move the entries to any target outside of the sub menus (or the opposite way)
   * functionality to create submenus(?)
   * functionality to delete submenus(?)
 * create a new proxyconfig format (it's a simple list this time)
 * functionality to write out the filtered stuff using to new proxyconfig
 * last but not least (may be the easiest thing of all): notice paths when changing the default entry from the settings dialog

hmm the new Grub2 seems to notice and prefer the settings, done in desktop-base… but I didn't get it working by simply modifying the /etc/default/grub… hmm…

drs305 (drs305) wrote :

On Thu, 2011-05-12 at 19:28 +0000, Daniel Richter wrote:
> Yes, I noticed the typo (wondered, how grub2 should separate the "," as
> delimiter in opposite to the "," inside the title ;-) ).
>
> The submenu feature seems to be much work as I have to:
> * detect it while parsing; parsing the second layers
> * build the tree inside the entry list
> * but the user should still be able to move the entries to any target outside of the sub menus (or the opposite way)
> * functionality to create submenus(?)
> * functionality to delete submenus(?)
> * create a new proxyconfig format (it's a simple list this time)
> * functionality to write out the filtered stuff using to new proxyconfig
> * last but not least (may be the easiest thing of all): notice paths when changing the default entry from the settings dialog
>
> hmm the new Grub2 seems to notice and prefer the settings, done in
> desktop-base… but I didn't get it working by simply modifying the
> /etc/default/grub… hmm…
>

I know it's a big change. I didn't report anything because I knew it
would take time. Some of our forumites started posting, so I thought I'd
better file something.

The image selection is also pretty convoluted. I wrote a guide about
that as well. The usual disclaimer that I'm in no way related to the
development work and anything I write is just based on my usage and
could be incorrect. ;-)

Image Priorities:

1. GRUB_BACKGROUND=</path/filename> setting in /etc/default/grub
        Available in updated versions of Grub 1.98
        Example: GRUB_BACKGROUND=/boot/grub/myimages/eyecandy.png
2. First image found in /boot/grub
        The first image found, in this order: jpg, JPG, jpeg, JPEG, png,
PNG, tga, TGA
        If multiple images of the same extension, alphanumerically.
3. Wallpaper designated in /usr/share/desktop-base/grub_backgorund.sh
(if desktop-base installed)
4. /usr/share/images/desktop-base/desktop-grub.png (if desktop-base is
installed)
5. Default theme (no image): Aubergine background, selected item black
on light gray background)

I noticed that you use your own designation for the Grub background
image variable in /etc/default/grub, and since G1.99 only looks for
GRUB_BACKGROUND it defaults to anything in /boot/grub as the next
option.

http://ubuntuforums.org/showthread.php?t=1739412
On G1.99 background images.

Ok, finally I got it working (grub2 didn't like the default wallpapers of ubuntu :-( - but my own picture were accepted).

The current theme related functionality of grub customizer is ok basically. The only problem is the button "copy to grub directory": the user mustn't click it when using this new version of grub to get both working (background image and colors). Also every existing image has to be removed from there.

The good news: the user doesn't have to decide if copying to grub directory is required or not anymore: the grub script automatically detects if this is required and caches the file itself. So I should remove this button when using this new version of grub.

Changed in grub-customizer:
status: In Progress → Fix Committed
Changed in grub-customizer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers