Ensure compatiblity with launchpadlib 1.9.7

Bug #737693 reported by Leonard Richardson on 2011-03-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ground Control
High
Martin Owens

Bug Description

This bug is to track any changes that need to be made to this package
to make it compatible with launchpadlib 1.9.7, the version of
launchpadlib currently in Natty. Forgive the formal tone; I'm filing a
lot of these bugs at once.

In late February, I performed an audit of this project's code and
spoke on IRC with the project maintainer, so this should not be a huge
surprise. If Natty already contains a compatible version of your
package, just mark this bug "Fix Released".

If you have any questions, feel free to respond in this bug. For a
guide to the changes in Natty's launchpadlib, see this mailing list
message:

https://lists.launchpad.net/launchpad-users/msg06239.html

My audit did not find any major issues that need to be addressed
immediately, but I'd like you to test it out yourself just to make
sure. I did find some minor issues that can probably be resolved
later, but which might cause deprecation errors, now or in the future:

* Use of deprecated server 'edge'. Use 'production' instead.

I had concerns about daemon.py, which sniffs the user's active Launchpad cookie
and simulates a browser session, but doctormo convinced me that this was
necessary for the time being, until it becomes possible to manipulate ssh keys
through a web service.

Martin Owens (doctormo) on 2011-03-18
Changed in groundcontrol:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Martin Owens (doctormo)
Stephen Boddy (stephen-j-boddy) wrote :

I almost made a seperate bug report till I realised that the issue I'm seeing is a result of the issue listed here:
"* Use of deprecated server 'edge'. Use 'production' instead."

The Fix Bug buttons bug search cannot see bugs > 963999

GC is making calls against edge which is deprecated. Presumably edge stopped getting updated after 963999.

Needs updating to use the production servers.

Stephen Boddy (stephen-j-boddy) wrote :

Should add that this is with 1.6.6 (the current stable release) Haven't tried 2.0 because I wasn't aware of it till just now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers