selected branch fails to download

Bug #627172 reported by Brian Dunnette on 2010-08-31
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ground Control
Undecided
Unassigned
groundcontrol (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: groundcontrol

Ubuntu 10.04
Ground Control 1.6.5-1

Expected Behavior:
Click "Fetch Branch", select branch & local name; branch content downloads to project folder

Actual Behavior:
Click "Fetch Project", select project -- project folder is created
Browse to project folder
Click "Fetch Branch", select branch & local name; "Retrieving Data" dialog appears, but no data is downloaded

Martin Owens (doctormo) wrote :

Does this problem appear in 1.6.6 which is available in Debian and the ppa?

https://edge.launchpad.net/~doctormo/+archive/groundcontrol

Brian Dunnette (bdunnette) wrote :

Yes -- the same behavior occurs after upgrading to 1.6.6 via the PPA.

Martin Owens (doctormo) wrote :

OK so it's reproducible and your using the latest, I will need to get you to run from the command line and give me a log here so I can understand what is going on. Right now your instructions work on my machine.

touch ~/groundcontrol.log
nautilus --quit; nautilus --no-desktop

Then reproduce your error, you may have to try it more than once to get the result in the log.

Brian Dunnette (bdunnette) wrote :

Hmm... from the log, it appears that it's failing when looking for a Python module named "winrandom"?

Full log is attached, including two failed attempts to download branches...

On 09/02/2010 06:48 PM, Brian Dunnette wrote:
> Hmm... from the log, it appears that it's failing when looking for a
> Python module named "winrandom"?
>
> Full log is attached, including two failed attempts to download
> branches...
>
> ** Attachment added: "groundcontrol.log"
> https://bugs.launchpad.net/groundcontrol/+bug/627172/+attachment/1538199/+files/groundcontrol.log
>
From the log, it looks like the issue is that the Crypto module is
importing winrandom, which is a Windows-only library. Normally, this
import would fail and the module would go onto an alternative.

I think hg tries to speed up its runtime by delaying Python imports
until the imported code is used. This breaks the behavior of some
modules, because they depend on imports of non-extant modules to fail
during import, not usage.

--
╒═════════════════════════════════════════════════════════════════╕
│Luke Faraone ╭Debian / Ubuntu Developer╮│
http://luke.faraone.cc ╰Sugar Labs, Systems Admin╯│
│PGP: 5189 2A7D 16D0 49BB 046B DC77 9732 5DD8 F9FD D506 │
╘═════════════════════════════════════════════════════════════════╛

Martin Owens (doctormo) wrote :

Luke: Yes that's what I thought. I gave this branch a download last night myself and it worked perfectly on Ubuntu 10.04 i386 with 1.6.6 from the ppa. So this error must be something to do with some package installed on Brian's machine.

Brian can you confirm?

Affects me at groundcontrol 1.6.7 from ppa.
attached log mentions winrandom module.

Andrei Dziahel (develop7) wrote :

@doctormo, have you tried to reproduce this bug after installing mercurial?

Martin Owens (doctormo) wrote :

@Andrei - Yes, I just installed mecurial on ubuntu 10.10 and tried to download the branch shown in the logs. No error occurred :-(

Jan Girlich (vollkorn) wrote :

I can confirm this bug, too. I run the latest Ubuntu 10.10 with the ground-control 1.6.6-1 from the repositories.
Same error message, mercurial was installed all the time.

Running
touch ~/groundcontrol.log
nautilus --quit; nautilus --no-desktop

Lead to hundreds of nautilus windows opening and pestering my taskbar, but the windows were not clickable nor alt-tab helped reaching them. Console output was:
jan@jan-x61:~$ touch ~/groundcontrol.log
jan@jan-x61:~$ nautilus --quit; nautilus --no-desktop
Initializing nautilus-image-converter extension
Initializing nautilus-gdu extension
Bazaar nautilus module initialized
Initializing groundcontrol-1.6.6 extension
Initializing nautilus-dropbox 0.6.7
sys:1: GtkWarning: IA__gtk_container_foreach: assertion `GTK_IS_CONTAINER (container)' failed

Changed in groundcontrol:
status: New → Incomplete
status: Incomplete → Confirmed
Jan Girlich (vollkorn) wrote :

Oh, I got some output! Hinting at SSL problems. See attached logfile.

Jan Girlich (vollkorn) wrote :

And here goes groundcontrol.log, but it reveals no news.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers