nautilus won't start as root

Bug #521330 reported by Tristan on 2010-02-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ground Control
Medium
Martin Owens

Bug Description

I've got groundcontrol 1.4 installed on Ubuntu 9.10. Whenever I try to start nautilus as root (from the terminal) I get the folllowing error:

root@tristan-laptop:/media/Fedora-12-i686-L/home/tristan# nautilus

(nautilus:3572): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

** (nautilus:3572): WARNING **: No marshaller for signature of signal 'UploadFinished'

** (nautilus:3572): WARNING **: No marshaller for signature of signal 'DownloadFinished'

** (nautilus:3572): WARNING **: No marshaller for signature of signal 'ShareCreateError'
Initializing nautilus-gdu extension
Initializing groundcontrol-1.4 extension
Traceback (most recent call last):
  File "/usr/lib/nautilus/extensions-2.0/python/nautilus-groundcontrol.py", line 60, in __init__
    self.xdg_dir = PROJECT_XDG.get_data_path('projects', HOME_DIR)
  File "/usr/lib/python2.6/dist-packages/xdgapp.py", line 86, in get_data_path
    content = self.get_config('user-dirs.dirs', False)
  File "/usr/lib/python2.6/dist-packages/xdgapp.py", line 113, in get_config
    if os.path.exists(conf):
UnboundLocalError: local variable 'conf' referenced before assignment
Segmentation fault

I've checked both the groundcontrol.log in the root home and my home, and both are empty. I've also tried creating a Projects folder in root's home, and the error still exists.

(If you're wondering why I'm trying to start nautilus as root its because I need to copy some files accross from my Fedora installation home which won't allow me to access the files without being root)

Martin Owens (doctormo) on 2010-02-14
Changed in groundcontrol:
status: New → Confirmed
importance: Undecided → Medium
Martin Owens (doctormo) on 2010-02-16
Changed in groundcontrol:
status: Confirmed → Fix Committed
assignee: nobody → Martin Owens (doctormo)
milestone: none → 1.5
Martin Owens (doctormo) on 2010-02-16
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers