GC postinst should not modify configuration files owned by other packages

Bug #521263 reported by Luke Faraone on 2010-02-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ground Control
Critical
Martin Owens

Bug Description

debian/posinst contains these lines:
    # We need to update the xdg-dirs to add a
    # new default directory for projects
    if ! grep -q '^PROJECTS=' /etc/xdg/user-dirs.defaults; then
      echo '# Added by groundcontrol' >> /etc/xdg/user-dirs.defaults
      echo 'PROJECTS=Projects' >> /etc/xdg/user-dirs.defaults
    fi;

This has to be removed, of course, but there are three things we can do from here: (from least to most work)

 1) Do nothing, and leave the file unchanged
 2) Add a maintainer script for xdg-user-dirs giving us the ability to modify the configuration file
 3) Get the stanza added to the configuration file by default

Luke Faraone (lfaraone) on 2010-02-13
tags: added: debian-packaging
Martin Owens (doctormo) wrote :

If the xdg/user-dirs.defaults is left unchanged then Ground Control will assume that it is always deactivated.

It will never work.

We need someone to solve this problem, because this is the best I could come up with. If it's not allowed, then I'm all out of ideas and a real MOTU should let us know what the right way of doing this is.

Martin Owens (doctormo) on 2010-02-14
Changed in groundcontrol:
status: New → Confirmed
importance: Undecided → Critical
Martin Owens (doctormo) on 2010-02-14
Changed in groundcontrol:
status: Confirmed → Fix Committed
assignee: nobody → Martin Owens (doctormo)
milestone: none → 1.5
Martin Owens (doctormo) on 2010-02-16
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers