GC makes nautilus hang when shift+delete directories from the Projects directory

Bug #520351 reported by Łukasz Jernaś on 2010-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ground Control
Critical
Martin Owens

Bug Description

When shift+deleting a directory inside Projects with GC enabled I get the confirmation dialog and then everything just hangs indefinetely. I can't get any meanignful info from the ~/groundcontrol.log file (it's empty) nor from gdb:
(gdb) bt
#0 __lll_lock_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:136
#1 0x00007fc7f3412439 in _L_lock_949 () from /lib/libpthread.so.0
#2 0x00007fc7f341225b in __pthread_mutex_lock (mutex=0x2e16cd0) at pthread_mutex_lock.c:61
#3 0x00007fc7f2937fae in gdk_event_prepare (source=0x2e16cd0, timeout=0x7fff3449793c) at /build/buildd/gtk+2.0-2.19.5/gdk/x11/gdkevents-x11.c:2326
#4 0x00007fc7f11f64d1 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#5 0x00007fc7f11f6938 in ?? () from /lib/libglib-2.0.so.0
#6 0x00007fc7f11f726d in g_main_loop_run () from /lib/libglib-2.0.so.0
#7 0x00007fc7f2ce8677 in IA__gtk_main () at /build/buildd/gtk+2.0-2.19.5/gtk/gtkmain.c:1219
#8 0x0000000000444314 in main (argc=1, argv=0x7fff34497e68) at nautilus-main.c:583

Related branches

tags: added: lucid
Martin Owens (doctormo) wrote :

Sounds pretty bad, but we'll need to do some investigations. Can you give exact steps which replicate the problem hopefully every time you perform those actions?

Martin Owens (doctormo) on 2010-02-11
Changed in groundcontrol:
importance: Undecided → Critical
status: New → Triaged
Łukasz Jernaś (deejay1) wrote :

Places -> Home dir -> Projects -> Fetch Proejct -> "ground control" Find -> select ground control dir -> shit+delete -> click "Delete"

Effect: Nautilus hangs with a pressed "Delete" button, but directory gets deleted

groundcontrol.log
2-12 11:04 root INFO Save cache file to /home/deejay1/.cache/launchpad/credentials/Launchpad Ground Control-edge.txt
02-12 11:04 root DEBUG Loading Launchpad connection...
02-12 11:04 root DEBUG -- Poll Start project_search --
02-12 11:04 root DEBUG Starting new GTK Main Loop.
02-12 11:04 root DEBUG Calling finish_search
02-12 11:04 root DEBUG -- Poll Quit project_search --
02-12 11:04 root DEBUG Search projects for groundcontrol
02-12 11:04 root DEBUG -- Poll Start project_search --
02-12 11:04 root DEBUG Calling add_search_item
02-12 11:04 root DEBUG Looking for image file '/home/deejay1/.cache/launchpad/oauth/groundcontrol-logo.png'
02-12 11:04 root DEBUG ..Loading image file '/home/deejay1/.cache/launchpad/oauth/groundcontrol-logo.png'
02-12 11:04 root DEBUG Finished Search
02-12 11:04 root DEBUG Calling add_search_item
02-12 11:04 root DEBUG Calling finish_search
02-12 11:04 root DEBUG -- Poll Quit project_search --
02-12 11:05 root DEBUG Applying changes
02-12 11:05 root DEBUG Calling callback function for window
02-12 11:05 root DEBUG -- Poll Start status_window --
02-12 11:05 root DEBUG Starting new GTK Main Loop.
02-12 11:05 root DEBUG Looking for image file '/home/deejay1/.cache/launchpad/oauth/groundcontrol-brand.png'
02-12 11:05 root DEBUG Looking for image file '/home/deejay1/.cache/launchpad/oauth/groundcontrol-logo.png'
02-12 11:05 root DEBUG Looking for image file '/home/deejay1/.cache/launchpad/oauth/groundcontrol-icon.png'
02-12 11:05 root DEBUG -- Poll Quit status_window --
02-12 11:05 root DEBUG Cancelled or no callback for window
02-12 11:05 root DEBUG Quit 'status_window' Main Loop.
02-12 11:05 root DEBUG Quit 'project_search' Main Loop.
02-12 11:05 root DEBUG Loaded project groundcontrol
02-12 11:05 root DEBUG Set emblem Ground Control

.xsession-errors

(gnome-terminal:3364): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
sys:1: Warning: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

** (nautilus:3008): CRITICAL **: dbus_g_proxy_begin_call: assertion `DBUS_IS_G_PROXY (proxy)' failed
/usr/lib/pymodules/python2.6/GroundControl/gtkviews.py:99: GtkWarning: gtk_widget_event: assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed
  gtk.main()

Martin Owens (doctormo) wrote :

It looks like it happens after any window has been opened, it's locking the GIL so when another nautilus window pops up it locks up.

It's going to be hard to fix.

Changed in groundcontrol:
status: Triaged → Confirmed
assignee: nobody → Martin Owens (doctormo)
Martin Owens (doctormo) on 2010-02-15
Changed in groundcontrol:
status: Confirmed → Fix Committed
milestone: none → 1.5
Martin Owens (doctormo) on 2010-02-16
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers