necessary to translate debug output ?

Bug #516651 reported by bernhard on 2010-02-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ground Control
Low
Martin Owens

Bug Description

is it realy necessary to translate every single debug message?

for example:
logging.debug(_("Feeding in cookie '%s'") % self.session)

is this text worth translating it into a lot of languages?
i also think the user would get a harder time to google for localized debug error messages.

Related branches

bernhard (bernhardredl) wrote :
Changed in groundcontrol:
status: New → Invalid
Martin Owens (doctormo) wrote :

No, this is a good place to discuss the problem. I'm not so sure myself about translating debug message. I'd like to hear from more advanced developers about how they solve this issue.

Changed in groundcontrol:
status: Invalid → Confirmed
importance: Undecided → Medium
importance: Medium → Low
Markus Korn (thekorn) wrote :

I don't think translating debug logging messages in general is a good idea.
These debug messages are often use to help the developer (fx in bugreports) to understand what is going wrong, and if these messages are translatet to a language he/she does not understand it will make things much harder.

Martin Owens (doctormo) wrote :

How does this idea around:

Translate error messages.

Don't translate debugs and warnings.

This way we get to tell the user about errors, but devs get logs that make sense.

Errors will normally be obvious anyway, since there is a traceback.

Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
status: Confirmed → Fix Committed
assignee: nobody → Martin Owens (doctormo)
milestone: none → 1.2
Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers