Ignore automatically created files when committing

Bug #515335 reported by Robert Schroll on 2010-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ground Control
High
Martin Owens

Bug Description

I used Ground Control to download and edit Metacity. After making my changes, but before committing, I ran autogen.sh and then make, so that I could check that my changes worked. When I tried to commit, Ground Control wanted to commit all of those auto-generated files from the configuration process. To avoid this, I deleted all of these files by hand before making the commit. I don't think I had to delete the object and executable files, so it obviously can avoid some files it shouldn't commit; perhaps this logic can be improved.

Two other solutions that would help work-around this issue:
1) Add an "ignore this file" button to the modification listing in the commit dialog. In my case, this would still have been a lot of clicking, but it would have been easier than all of the deletions.
2) Don't add newly-created files by default; only commit modifications to previously-existing files. Since most of us using Ground Control will be making quick fixes to exiting code, we won't usually want to add new files. I'm guessing that the people who do need to add new files would be able to do it manually with bzr.

Thanks for this handy tool!

Related branches

Martin Owens (doctormo) wrote :

Yes there is a balance to strike between adding files automatically because they are new, and not adding files because they are transitory.

The problem is that if we don't add files, new users will not have a workflow for adding them, but if we do add files, we risk adding tempary files.

I think what is required is some clever logic that a) picks some usual suspects to ignore b) allows the user to select files from the commit and c) Allows user to select none of the additional files in one simple button.

Changed in groundcontrol:
status: New → Confirmed
importance: Undecided → Medium
Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
importance: Medium → High
assignee: nobody → Martin Owens (doctormo)
Martin Owens (doctormo) wrote :

I've added a simple checkbox which when clicked will ignore all new files. this does mean that you won't be able to add new files.

Though if you'd like to see the files permanently ignored, then create a new bug report for that functionality.

Changed in groundcontrol:
milestone: none → 1.2
status: Confirmed → Fix Committed
Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers