'Special key' wizard: maybe ignoring some existing uploaded keys

Bug #515251 reported by Ludovic Claude on 2010-01-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ground Control
Medium
Martin Owens

Bug Description

I am an existing Launchpad developer, with my own set of PGP keys. When I setup my 'Project' folder, Groundcontrol asks me to create a new set of keys. Is that necessary, and is there a way to reuse my existing keys?

Related branches

Martin Owens (doctormo) wrote :

Hey,

It's not the GPG keys that it's checking, it's the SSH keys, it checks your user's private/public keys in ~/.ssh/ and checks to see if you have a public part online in launchpad. Could you just confirm for me that your ssh key (public part) is online in launchpad and that ground control doesn't verify it correctly?

I have an existing ssh key and so it didn't ask me to make a new one.

Martin Owens (doctormo) on 2010-01-31
Changed in groundcontrol:
status: New → Incomplete
summary: - 'Special key' wizard: should be able to reuse exising keys
+ 'Special key' wizard: maybe ignoring some existing uploaded keys
Ludovic Claude (ludovicc) wrote :

I checked, and my Launchpad key had the same contents but a different comment ( the part after == ), more exactly a different email address. After I updated my SSH key in Launchpad with the latest email address, it worked. Thanks

Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Martin Owens (doctormo) on 2010-02-14
Changed in groundcontrol:
importance: Wishlist → Medium
Martin Owens (doctormo) on 2010-02-16
Changed in groundcontrol:
status: Confirmed → Fix Committed
assignee: nobody → Martin Owens (doctormo)
milestone: none → 1.5
Martin Owens (doctormo) on 2010-02-16
Changed in groundcontrol:
status: Fix Committed → Fix Released
Paul Natsuo Kishimoto (khaeru) wrote :

Still unable to commit code with the setup described in bug #520052, which was marked as a duplicate of this one. I now get a dialog titled 'Bazaar Error', with the text:

Failed to gpg sign data with command "['gpg', '--clearsign']"

Changed in groundcontrol:
status: Fix Released → Confirmed
Martin Owens (doctormo) wrote :

Please create a new bug report instead of re-opening a bug marked 'fix released' the bug I got the impression from this report has been fixed and what you describe is a brand new problem which needs a brand new report to track it.

Changed in groundcontrol:
status: Confirmed → Fix Released
Paul Natsuo Kishimoto (khaeru) wrote :

When my original bug was marked "Duplicate", I though that meant it had been positively identified as having the same cause as this one. I have no way to tell if the fix was aimed only at this report and not my own, linked report.

I removed the "Duplicate" tag from the other bug and backlinked to comment #3.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers