"Load Code" bar does not appear for some projects.

Bug #514751 reported by Matthew Pirocchi on 2010-01-30
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ground Control
Critical
Martin Owens

Bug Description

I just installed Ground Control from the PPA, and added the "Docky" project. When I entered the "docky" folder, the "Load Code" bar appeared. I loaded trunk, and everything worked as expected.

I then searched for "Cardinal"--a little spaced-repetition program I am working on. I added it, and Ground Control created a "cardinal" folder as expected. However, when I enter this folder, there is no "Load Code" bar. I went back to the "docky" folder, and the "Load Code" bar is still there.

Why does Ground Control work for Docky, but not for Cardinal?

Related branches

Martin Owens (doctormo) wrote :

I just confirmed it,

The real error is this:

WARNING Can't find icon for /home/doctormo/Projects/cardinal/.logo.png in /home/doctormo/Projects/python/ground-control/groundcontrol/pixmaps/
Traceback (most recent call last):
  File "/home/doctormo/.nautilus/python-extensions/nautilus-groundcontrol.py", line 139, in get_widget
    widget.icon(os.path.join(self._path, '.logo.png'))
  File "/home/doctormo/.nautilus/python-extensions/nautilus-groundcontrol.py", line 353, in icon
    endresult = pixbuf.scale_simple(32, 32, gtk.gdk.INTERP_BILINEAR)
AttributeError: 'NoneType' object has no attribute 'scale_simple'

This is because Cardinal doesn't have any branding, although default branding should have kicked in.

Changed in groundcontrol:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Martin Owens (doctormo)
milestone: none → 1.2
arky (arky) wrote :

Problem can be reproduced for other projects like gnome-orca.

Traceback (most recent call last):
  File "/usr/lib/nautilus/extensions-2.0/python/nautilus-groundcontrol.py", line 133, in get_widget
    widget.icon(os.path.join(self._path, '.logo.png'))
  File "/usr/lib/nautilus/extensions-2.0/python/nautilus-groundcontrol.py", line 346, in icon
    endresult = pixbuf.scale_simple(32, 32, gtk.gdk.INTERP_BILINEAR)
AttributeError: 'NoneType' object has no attribute 'scale_simple'

Paul Natsuo Kishimoto (khaeru) wrote :

Also: gnucash, goffice.

Martin Owens (doctormo) on 2010-02-02
Changed in groundcontrol:
status: Confirmed → Fix Committed
Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers