Translation

Bug #514010 reported by Ddorda on 2010-01-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ground Control
Critical
Martin Owens

Bug Description

There's no PO on the translation area, so the program is not translatable yet...

Martin Owens (doctormo) wrote :

We don't have any translation integration in the code yet, we need a programmer that knows how to do that first.

Changed in groundcontrol:
importance: Undecided → Critical
status: New → Confirmed
Ddorda (ddorda) wrote :

I'm working to make that change, i'll let you know when i'll finish (it will take me a little while)..

Ddorda (ddorda) wrote :

question: do you want the logging.debug strings to be translated? i believe it shouldn't be translated, but after all it's your project :P

Martin Owens (doctormo) wrote :

Ddorda, I think translating the logging output is important, but I'd also want to make sure that there was a way for the output to come out in English as well as the target langauge. If someone attaches a report with a french log, I may not be able to fix the problem because I can't read it.

The other thing, is it possible to make more than one pot file? or is it one translation service per project? seperating out the debug strings from the app strings would be useful.

Ddorda (ddorda) wrote :

It is possible to make a POT per file as much as i know.
all i know i learned from here: http://wiki.laptop.org/go/Python_i18n

Martin Owens (doctormo) wrote :

I've attached a branch that is also adding in i11n support, are you guys aware of each other's work?

Ddorda, if you've not yet started work on it, could you review the branch and confirm it's of good working order? If you have started work, could you push the branch and we can attach and compare and combine?

Ddorda (ddorda) wrote :

I've finished it, but then i figured out most of my job was for nothing since it includes the logging.debug.
today i had much fewer time, so i didn't finished doing it again..

I'll try this branch later tomorrow morning... (it's 20:00 here)

Martin Owens (doctormo) on 2010-02-02
Changed in groundcontrol:
status: Confirmed → Fix Committed
assignee: nobody → Martin Owens (doctormo)
Ddorda (ddorda) wrote :

please ad the POT into the translation area in launchpad so we can translate on line.. thanks!

Martin Owens (doctormo) on 2010-02-03
Changed in groundcontrol:
milestone: none → 1.2
Martin Owens (doctormo) on 2010-02-04
Changed in groundcontrol:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers