grok trunk - buildout broken

Bug #377868 reported by Michael Haubenwallner on 2009-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grok
Undecided
Unassigned

Bug Description

I ran buildout on a trunk checkout today and found it broken (also tried on a new egg directory).

Any idea which package pulls in zope.container
or why it is not included with version.cfg?

See part of the buildout output below:
...
Getting distribution for 'zope.contenttype==3.4.0'.
Got zope.contenttype 3.4.0.
Getting distribution for 'zope.app.exception==3.4.1'.
Got zope.app.exception 3.4.1.
Getting distribution for 'zope.index==3.4.1'.
Got zope.index 3.4.1.
Getting distribution for 'zope.container'. <<<<<<<<<<<<<<
Got zope.container 3.8.2. <<<<<<<<<<<<<<
Getting distribution for 'zodbcode==3.4.0'.
Got zodbcode 3.4.0.
...
Getting distribution for 'zope.broken'.
Got zope.broken 3.5.0.
While:
  Installing interpreter.
Error: There is a version conflict.
We already have: zope.lifecycleevent 3.4.0
but zope.container 3.8.2 requires 'zope.lifecycleevent>=3.5.2'.

Michael Haubenwallner (d2m) wrote :

grokcore.view 1.5 depends on 'zope.container'
but it is not included with the versions.cfg

Michael Haubenwallner (d2m) wrote :

pinned zope.container to 3.8.1 in versions.cfg und updated the trunk
will remove after changes to grokcore.view are released

Changed in grok:
status: New → Fix Committed
Michael Haubenwallner (d2m) wrote :

JWK did a new grokcore.view 1.7 and a Grok 1.0a4 release, everything working fine again

Changed in grok:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers