Remove Pygments and docutils from versions.cfg

Bug #340170 reported by Kevin Teague on 2009-03-09
4
Affects Status Importance Assigned to Milestone
grok
Low
Uli Fouquet

Bug Description

The versions.cfg specifies two packages, 'docutils' and 'Pygments'. Neither of these packages are used by Grok (to the best of my knowledge) and so should be removed. Historically, I believe these packages were pulled in as requirements for building the Sphinx-based Grok documentation. But the grokdocs sub-package now specifies these packages itself, so this should no longer necessary.

Uli Fouquet (uli-gnufix) wrote :

IIRC we build the eggbasket from versions.cfg, right? We indeed do not need docutils and Pygments in there.

The other thing is, that we need special versions of Pygments and docutils for generating docs. These could be pinned down in grokdocs/setup.py (which already happened, except for Pygments) as this subpackage is not released.

+1 for removing them from versions.cfg.

Uli Fouquet (uli-gnufix) on 2009-06-10
Changed in grok:
assignee: nobody → Uli Fouquet (uli-gnufix)
importance: Undecided → Low
status: New → In Progress
Uli Fouquet (uli-gnufix) wrote :

Both packages were removed from grok trunk's versions.cfg.

Changed in grok:
status: In Progress → Fix Committed
Changed in grok:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers