ConfigurationError: ('Unknown directive', u'http://namespaces.zope.org/help', u'register')

Bug #239556 reported by Kevin Teague on 2008-06-12
4
Affects Status Importance Assigned to Milestone
grok
Low
Brandon Rhodes
1.0
Low
Brandon Rhodes

Bug Description

When using ldapadapter version 0.6 with Grok 0.12.1 I get:

File "/Users/kteague/buildouts/shared/eggs/zope.configuration-3.4.0-py2.4.egg/zope/configuration/config.py", line 486, in factory
    raise ConfigurationError("Unknown directive", ns, n)
zope.configuration.xmlconfig.ZopeXMLConfigurationError: File "/Users/kteague/buildouts/gum/parts/app/site.zcml", line 4.0-4.25
    ZopeXMLConfigurationError: File "/Users/kteague/buildouts/gum/src/gum/configure.zcml", line 4.2-4.37
    ZopeXMLConfigurationError: File "/Users/kteague/buildouts/gum/src/ldapadapter/src/ldapadapter/configure.zcml", line 44.2
    ConfigurationError: ('Unknown directive', u'http://namespaces.zope.org/help', u'register')

If I remove the help:register directive from the ldapadapter package, everything works fine. Should help:register be removed from ldapadapter, or should Grok be able to handle or ignore that directive?

todd (todd-infrae) on 2008-12-10
Changed in grok:
assignee: nobody → brandon-rhodes
milestone: none → 1.0
Martijn Faassen (faassen) wrote :

Kevin, is this still a problem with more recent versions of Grok?

Kevin Teague (kevin-bud) wrote :

Not sure if this is still a problem w/ Grok - but I did go ahead and remove this directive from the ldapadapter ZCML and released that change w/ ldapadapter version 0.7, which solved the problem in a fashion.

I tried to do some spelunking regarding the help:register directive, but couldn't really come up with too much information on it's existance within Zope 3. Either it's underdocumented, an orphaned feature, or I just wasn't looking in the right place?

Uli Fouquet (uli-gnufix) wrote :

Hey Kevin,

looks to me, there is a ``help`` namespace defined in `zope.app.onlinehelp`.

To sum it up: ldapadapter should declare a dependency from zope.app.onlinehelp or the namespace should be removed from configure.zcml. You did the latter which makes sense, as the help-file to be registered seems not to exist in the package.

What looks strange to me: `zope.app.onlinehelp` is part of the dependencies of Grok 0.12.1 IIRC. Could the issue have been a problem with the autoInclude-directive?

Christian Klinger (cklinger) wrote :

zope.app.onlinehelp is out of the tzk so we give this bug a won't fix

Changed in grok:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers