zope.app.securitypolicy egg missing

Bug #229677 reported by Martijn Faassen on 2008-05-12
4
Affects Status Importance Assigned to Milestone
grok
Low
Uli Fouquet

Bug Description

When upgrading from an older version to Grok 0.12, the zope.app.securitypolicy egg disappeared. This egg is only a compatibility shell to zope.securitypolicy now, but it emits very useful deprecation warninsg to the user.

We should include zope.app.securitypolicy again (in addition to zope.securitypolicy) in Grok 0.12.1 (and the next major release as well).

Uli Fouquet (uli-gnufix) wrote :

This solution sounds reasonable to me, I'll have a look if it could break something else and do the changes if there are no objections.

Changed in grok:
assignee: nobody → uli-gnufix
importance: Undecided → Low
status: New → Confirmed
Uli Fouquet (uli-gnufix) wrote :

With Grok 0.11.1 we fetched the 3.4.0a1 release of zope.app.securitypolicy.

This release did not emit any deprecation warnings, so that reintroducing it again would not make much sense to me. Users wouldn't get warned about the old package. The newest release by now is 3.4.6 and I found no problems working with it and Grok. Are there any other things to take care of? Otherwise I would introduce this package (and not 3.4.0a1) into the Grok dependencies.

Do we need a test about the emitted deprecation warning?

On Wed, May 14, 2008 at 4:48 PM, Uli Fouquet <email address hidden> wrote:
> With Grok 0.11.1 we fetched the 3.4.0a1 release of
> zope.app.securitypolicy.
>
> This release did not emit any deprecation warnings, so that
> reintroducing it again would not make much sense to me. Users wouldn't
> get warned about the old package. The newest release by now is 3.4.6 and
> I found no problems working with it and Grok. Are there any other things
> to take care of? Otherwise I would introduce this package (and not
> 3.4.0a1) into the Grok dependencies.

I'm confused about your mention of 0.11. The problem started with 0.12
(not 0.11), where, I think, we switched to zope.securitypolicy, and
don't use zope.app.securitypolicy anymore. We should re-introduce
zope.app.securitypolicy again (with a newer version, that emits
deprecation warnings). I just looked at 3.4.6, and this is the version
that should emit deprecation warnings, so that should be all right.

Regards,

Martijn

Uli Fouquet (uli-gnufix) wrote :

Added zope.app.securitypolicy 3.4.6 to the requirements in setup.py and versions.cfg.

Changed in grok:
status: Confirmed → Fix Committed

On 14 May 2008, at 19:33 , Uli Fouquet wrote:
> Added zope.app.securitypolicy 3.4.6 to the requirements in setup.py
> and
> versions.cfg.

Thanks Uli for fixing this. But the whole point of the problem was
that it'd be fixed with the next 0.12.x release, right? So I think
we're still missing a merge to the 0.12 branch.

Uli Fouquet (uli-gnufix) wrote :

Philipp von Weitershausen wrote:
> On 14 May 2008, at 19:33 , Uli Fouquet wrote:
> > Added zope.app.securitypolicy 3.4.6 to the requirements in setup.py
> > and
> > versions.cfg.
>
> Thanks Uli for fixing this. But the whole point of the problem was
> that it'd be fixed with the next 0.12.x release, right? So I think
> we're still missing a merge to the 0.12 branch.

Your're right. Sorry and thanks for the hint! Just fixed the 0.12 branch
as well.

--
Uli

Changed in grok:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers