grok introspector broken for zipped eggs

Bug #185414 reported by Martijn Faassen on 2008-01-23
6
Affects Status Importance Assigned to Milestone
grok
Undecided
Uli Fouquet
0.11
Undecided
Uli Fouquet
Trunk
Undecided
Uli Fouquet

Bug Description

The grok introspector in 0.11.1 breaks when it encounters a zipped egg, which you see when you browse zope packages.

Uli Fouquet (uli-gnufix) wrote :

This is functionality from zope.app.apidoc.

Grok currently requires zope.app.apidoc 3.4.0a1 while the zipped-eggs-problem is fixed (well, circumvented to be precisely; zipped modules are simply skipped) in zope.app.apidoc 3.4.0. An update of versions.cfg would at least bring back the `zope` package documentation in the docgrok browser.

If that would not break other things, I would suggest to update versions.cfg. I could deliver an appropriate test by tomorrow.

Upgrading to a more recent zope.app.apidoc would be good if this
doesn't pull in a lot more other newer
packages. After the fix we can do a 0.11.2 release. If this is too
much work though, let's wait until we upgrade the trunk to KGS's list
of packages, which should then fix this issue too, at least on trunk
and thus 1.0.

Uli Fouquet (uli-gnufix) on 2008-01-23
Changed in grok:
assignee: nobody → uli-gnufix
status: New → Confirmed
Uli Fouquet (uli-gnufix) wrote :

Checked the zope.app.apidoc `setup.py`s and `buildout.cfg`s. No new packages were added between 3.4.0a1 and 3.4.0.

Running buildout -n with a changed versions.cgf only updated the zope.app.apidoc package. Well, no wonder with version.cfg.

All tests are running fine after update.

This looks good to me. I'll now commit the changes to the trunk. At least the additional test is needed, no matter whether we do a 0.11.2 or wait until the KGS upgrade.

Uli Fouquet (uli-gnufix) on 2008-01-24
Changed in grok:
status: Confirmed → Fix Committed

Thanks for fixing this, Uli. THis bug also affects the 0.11.x branch, so I'm marking the Trunk as "Fix Committed" and 0.11 as "Confirmed". Once the bugfix is merged to the 0.11 branch, this can also be set to "Fix Committed."

todd (todd-infrae) on 2008-12-10
Changed in grok:
milestone: none → 1.0
Uli Fouquet (uli-gnufix) wrote :

Fixed and released since 0.12.

Changed in grok:
status: Confirmed → Fix Released
Uli Fouquet (uli-gnufix) wrote :

Released since 0.12.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers