using 'grok' in a unittest fails due to a lack of template languages

Bug #161948 reported by Martijn Faassen on 2007-11-11
2
Affects Status Importance Assigned to Milestone
grok
Undecided
Philipp von Weitershausen
0.11
Undecided
Philipp von Weitershausen
Trunk
Undecided
Philipp von Weitershausen

Bug Description

Previously my code could do use the 'grok()' function during a unittest and the tests would proceed to pass. In 0.11, the tests start to fail. This is because it is trying to Grok a view but no template languages (including .pt) are registered. A grok('grok.templatereg') makes the tests pass again.

We should consider doing this basic setup in grok() itself.

I'll take this one.

Changed in grok:
assignee: nobody → philipp-weitershausen
status: New → Confirmed

Fixed in r81744 on the 0.11 branch.

Fixed in r81749 on the trunk.

Changed in grok:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers