keystoneclient requirements update fails grenade because using stable/grizzly

Bug #1252057 reported by Brant Knudson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grenade
Undecided
Unassigned

Bug Description

I submitted a change to update the keystoneclient requirements to the latest here: https://review.openstack.org/#/c/56490/

When grenade runs, it fails due to

2013-11-17 16:58:51.262 | 2013-11-17 16:58:51 Installed /opt/stack/old/glance
2013-11-17 16:58:51.268 | 2013-11-17 16:58:51 Processing dependencies for glance==2013.1.5.a2.gf4aaf8e
2013-11-17 16:58:51.273 | 2013-11-17 16:58:51 error: Installed distribution iso8601 0.1.4 conflicts with requirement iso8601>=0.1.8
2013-11-17 16:58:51.279 | 2013-11-17 16:58:51 ++ failed

(This is from http://logs.openstack.org/90/56490/4/check/check-grenade-devstack-vm/1e44bda/console.html )

Note that the latest requirement for iso8601 is >=0.1.8, so that's what keystoneclient has now.

This is preventing us from keeping the keystoneclient requirements up to date, and also prevents us from other changes that require the fixes in the latest version of iso8601.

Revision history for this message
Brant Knudson (blk-u) wrote :

It looks like grenade is using stable/grizzly as the source and not stable/havana. I think once grenade is updated then this problem will go away.

summary: - keystoneclient requirements update fails grenade
+ keystoneclient requirements update fails grenade because using
+ stable/grizzly
Revision history for this message
Brant Knudson (blk-u) wrote :

It looks like this is being addressed in https://review.openstack.org/#/c/57066/

Dirk Mueller (dmllr)
Changed in grenade:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers