Ignores SIGTERM and SIGINT

Bug #960215 reported by Sergey "Shnatsel" Davidoff on 2012-03-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
Critical
Unassigned

Bug Description

On catching SIGTERM, Scratch prints:
[WARN 13:43:42.488488] [Application:114] Caught signal (15), exiting
[FATAL 13:43:42.488564] [Gtk] gtk_main_quit: assertion `main_loops != NULL' failed
[FATAL 13:43:42.488609] Scratch will not function properly.
and doesn't exit. Can also be seen as "killall scratch" having no effect.

Related branches

Same for SIGINT.

Same bug observed in BeatBox, but not in Switchboard. Looks like a bug in Granite.

summary: - Scratch ignores SIGTERM
+ Ignores SIGTERM and SIGINT
Mario Guerriero (mefrio-g) wrote :

Yes, it seems to be a granite's bug

Changed in scratch:
status: New → Invalid
Scott Ringwelski (sgringwe) wrote :

I believe this is on purpose, but either way it is definitely a Granite issue.

Changed in beat-box:
status: New → Invalid

Raising priority because it screws up Wingpanel in live session and a number of other things.

Changed in granite:
status: New → Confirmed
importance: Undecided → High
milestone: none → 0.1.1
Daniel Fore (danrabbit) on 2012-05-22
Changed in granite:
importance: High → Critical
Cody Garver (codygarver) on 2012-06-18
Changed in granite:
status: Confirmed → Fix Committed
Changed in wingpanel:
status: New → Invalid
Changed in granite:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2013-04-15
no longer affects: beat-box
no longer affects: pantheon-wallpaper
no longer affects: scratch
no longer affects: wingpanel
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers