Help button theming broken in Precise

Bug #922581 reported by Cassidy James Blaede on 2012-01-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
Low
Victor Martinez
elementary Stylesheet
Fix Released
High
Unassigned

Bug Description

In builds based off of Ubuntu 12.04 Precise Pangolin, the Granite About dialog's help button shows up as broken. It's showing as a graphite oval with black text rather than a graphite circle with white text.

See screenshot.

Daniel Fore (danrabbit) wrote :

Some things changed in GTK from Oneiric to Precise. Still trying to figure it all out ;)

Changed in egtk:
status: New → Confirmed
importance: Undecided → High

I'll help by reporting more bugs! xD

Daniel Fore (danrabbit) wrote :

This (the color) should be fixed now, but it looks like I can't fix the padding to make it circular again. I have a feeling there is something going on with this in Granite...

Changed in egtk:
status: Confirmed → Fix Committed
Changed in granite:
status: New → Confirmed
assignee: nobody → Victor Eduardo (victored)
Victor Martinez (victored) wrote :

The help button should always be circular and shouldn't depend on the padding specified in the theme. I found a way to do this a while ago but it introduces a weird bug where the changes are only seen when hovering the button. I'm investigating it ATM.

Daniel Fore (danrabbit) on 2012-02-26
Changed in egtk:
milestone: none → 3.0
Changed in granite:
assignee: Victor Eduardo (victored) → elementary Drive-by Contributors (elementary-driveby)
Changed in granite:
assignee: elementary Drive-by Contributors (elementary-driveby) → Victor Eduardo (victored)
importance: Undecided → Low
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2012-04-03
Changed in egtk:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2012-05-22
Changed in granite:
milestone: none → 0.1.1
Changed in granite:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers