Granite's current CMakeLists.txt unnecessarily depends on a C++ compiler being installed

Bug #1157522 reported by Michel Alexandre Salim on 2013-03-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
Medium
Michel Alexandre Salim

Bug Description

cmake assumes that projects are written in C++ by default, unless the project language is set. Since Granite doesn't, running cmake fails if a C++ compiler is not available, even though the compiler is never used during the build process

Related branches

Changed in granite:
status: New → Incomplete
status: Incomplete → Confirmed
assignee: nobody → Michel Alexandre Salim (hircus)
Cody Garver (codygarver) on 2013-03-20
Changed in granite:
importance: Undecided → Medium
status: Confirmed → Fix Released
milestone: none → luna-beta2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers