Slingshot doesn't hide after dragging icons

Bug #1051688 reported by Andrea Basso on 2012-09-16
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
High
Tom Beckmann

Bug Description

Try dragging an icon and drop it anywhere, now click outside Slingshot. It
won't close :(

Changed in slingshot:
status: New → Invalid
importance: High → Undecided
Andrea Basso (voluntatefaber) wrote :

Sorry for all those status updates, I've just misclicked too many times :(

Changed in slingshot:
status: Invalid → Won't Fix
status: Won't Fix → Confirmed
importance: Undecided → High
Victor Martinez (victored) wrote :

What's wrong with this behavior? I like to be able to drag as many launchers as I want (to the dock) without having to re-open slingshot.

Try dragging an icon and drop it anywhere, now click outside Slingshot. It
won't close, this is what the bug's about ;)

Victor Martinez (victored) wrote :

Ah! It makes sense now; thanks for the clarification. That should have been part of the description because the title doesn't sound like a bug ;)

description: updated
Changed in slingshot:
milestone: none → luna-beta2
Jaap Broekhuizen (jaapz-b) wrote :

I'm digging into this one, and it looks like the problem lies with the fact that the button_release_event is not called anymore after the drag is finished.

Jaap Broekhuizen (jaapz-b) wrote :

During the drag the main popover window loses the pointer grab, and doesn't get it back after the drag has ended. Pressing escape to close Slingshots resets the behaviour because it restores the pointer in the hide() method. I haven't got any further yet...

Alex Granizo (agranizo) wrote :

Bug confirmed. On a laptop with propietary AMD drivers (fglrx 9.002) it leads to a complete crash of X server.

Cody Garver (codygarver) wrote :

Proprietary AMD drivers are not supported because support for pantheon/gnome-shell/mutter is still in development by AMD.

Changed in slingshot:
assignee: nobody → Akshay Shekher (voldyman)
Changed in granite:
status: New → Confirmed
Changed in granite:
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Tom Beckmann (tombeckmann)
milestone: none → luna-beta2
status: Confirmed → Fix Committed
no longer affects: slingshot
Changed in granite:
status: Fix Committed → Triaged
Changed in granite:
status: Triaged → Fix Committed
Andrea Basso (voluntatefaber) wrote :

The taken solution is, IMO, wrong. https://bugs.launchpad.net/granite/+bug/1094015

Cody Garver (codygarver) on 2013-04-15
Changed in granite:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers