Gtk Spinner doesn't spin

Bug #1020355 reported by Daniel Fore on 2012-07-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Granite
Fix Released
High
xapantu
elementary Stylesheet
Fix Released
Undecided
Unassigned

Bug Description

In the Dynamic Notebook's tabs, the GTK Spinner doesn't appear to actually spin.

Related branches

Daniel Fore (danrabbit) wrote :

This seems to be a problem with GTK's spinner in general. I haven't seen an example of it working properly.

Changed in granite:
status: New → Invalid
xapantu (xapantu) wrote :

Uh, I don't think so. Gtk.Spinner::start is never called, it must be the problem.

Changed in granite:
status: Invalid → Confirmed
Scott Ringwelski (sgringwe) wrote :

No, this is a problem in Gtk. Although there may be an additional issue with granite.

Victor Martinez (victored) wrote :

Scott, I guess you were talking about GtkCellRendererSpinner. The normal widget works as long well as you call start() on it.

Changed in granite:
importance: Undecided → High

Stephen Smally on the mailing list reports that GTK spinners don't spin only in elementary theme; probably theme-related bug (missing animation?)

Scott Ringwelski (sgringwe) wrote :

Maybe its been fixed, but at one point the normal spinner widget did not work in any themes, and finally I talked with gtk devs in IRC and they confirmed it as a bug in Gtk.

Cody Garver (codygarver) wrote :

Xapantu, can you take another look at the merge review?

Changed in granite:
status: Confirmed → In Progress
assignee: nobody → xapantu (xapantu)
milestone: none → luna-beta1
Changed in granite:
status: In Progress → Fix Committed
Changed in granite:
status: Fix Committed → Fix Released
Changed in egtk:
status: New → Fix Committed
Daniel Fore (danrabbit) on 2013-02-20
Changed in egtk:
milestone: none → 3.3
Cody Garver (codygarver) on 2013-04-09
Changed in egtk:
status: Fix Committed → Fix Released
Pierre (pierrewinnipeg) wrote :

Gtk3 Spinner still not working in Ubuntu 13.04

I tried a number of spinner scripts, including one I had that worked in gtk2 as well as the one on this main tutorial

https://python-gtk-3-tutorial.readthedocs.org/en/latest/spinner.html#spinner-objects

I also tried 1/2 dozen from various websites and none of them spin.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers