modebutton returning a wrong index

Bug #1017231 reported by DavyS on 2012-06-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Granite
Fix Released
High
Victor Martinez

Bug Description

the modebutton widget return a wrong index.

line 155: "int item_index = (int)get_children ().length ();"
 should be "length () -1" because length start with 1 and index start with 0.

Related branches

Can any of the devs confirm this?

tags: added: bitesize
Changed in granite:
status: New → Confirmed
importance: Undecided → High
Changed in granite:
status: Confirmed → Fix Committed
assignee: nobody → Victor Eduardo (victored)
milestone: none → luna-beta1
Changed in granite:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers