Tap gesture goes back to Update state after End state.

Bug #949855 reported by Daniel d'Andrada on 2012-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Grail
High
Unassigned
utouch-grail (Ubuntu)
High
Unassigned

Bug Description

Steps to reproduce the problem:
  1- build and run the attached test app "tap-grail".
  2- perform a 4 fingers' tap on a touchscreen or trackpad
  3- watch the output on console

Expected outcome:
  there's one slice with Begin state, followed by a number slices with Update state and the last slice printed has End state.

Actual outcome:
  The last three slices have the following sates: End and then Update and then End again. See output.txt for a typical run.

Comments:
  Also notice that the last End state has only 3 touches.

Related branches

Daniel d'Andrada (dandrader) wrote :

Notice that an atomic subscription is used

Jussi Pakkanen (jpakkane) wrote :

I confirm that this happens on my machine as well using Magic Trackpad.

Changed in utouch-grail:
importance: Undecided → High
Changed in utouch-grail (Ubuntu):
importance: Undecided → High
Changed in utouch-grail:
status: New → Triaged
Changed in utouch-grail (Ubuntu):
status: New → Triaged
Changed in utouch-grail:
status: Triaged → Fix Committed
milestone: none → utouch-grail-3.0.3
Changed in utouch-grail:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package utouch-grail - 3.0.3-0ubuntu1

---------------
utouch-grail (3.0.3-0ubuntu1) precise; urgency=low

  [ Daniel d'Andrada ]
  * Updated debian/watch

  [ Stephen M. Webb ]
  * removed udeb package
  * debian/control: added Homepage, Vcs-Bzr, and Vcs-Browser fields

  [ Chase Douglas ]
  * Don't strip binaries in daily builds
  * Re-enable tests, integration tests won't build due to missing xorg-gtest
  * New upstream release.
    - Fix tap gesture ending and then erroneously updating (LP: #949855)
    - Fix premature atomic subscription gestures (LP: #949916)
    - Fix integration test build system (LP: #949933)
    - Fix memory growth of touch start time vector (LP: #955131)
    - Fix atomic tap gestures for very fast taps (LP: #957437)
    - Fix accepted tap gesture touches being rejected (LP: #960438)
 -- Chase Douglas <email address hidden> Wed, 21 Mar 2012 19:29:14 -0700

Changed in utouch-grail (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers