Gnome Partition Editor

resizing NTFS partition broke Windows Vista

Reported by robuust on 2008-11-14
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Critical
gparted (Baltix)
Undecided
Unassigned
gparted (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gparted

1) ubuntu 8.10 live cd

2) 1 day after 8.10 came out, so the most recent version

I shrinked my windows partition and made a new one for ubuntu, installed it without any problems.
then I thought, it would be handier for me to install it inside windows, so i booted up from the live cd, run gparted, removed the ubuntu and swap partition, and i rezised it.
all went well, (i think) but when i wanted to boot windows it said that C:/Windows/System32/winload.exe was missing, so i needed to repair windows (wich succeeded.

it may me due to a activiation crack, but i'm not sure, since the crack still works...

Joel Oliver (joelol75) wrote :

Possibly in removing the root / and swap directories grub was borked... You should boot the windows CD and goto the recovery console ("R") and log into the Windows install and type:

fixmbr

you can also try fixboot

This should fix the windows boot problem.

Please give more details. What kind of filesystem (fat32/ntfs/etc) is your Windows partition? Which version of Windows?

Changed in gparted:
status: New → Incomplete
robuust (robbiecuiper) wrote :

i already fixed it with windows repair, but hey, its still a bug :)
(i did it by booting from de vista dvd, and selected "repair my computer" or something like that)
fixmbr, fixboot does the same, actually :)

i use Windows Vista x64 on NTFS.

like i said, i just removed the ubuntu partition and resized the windows partition.

Tormod Volden (tormodvolden) wrote :

Did you test Vista after shrinking the NTFS partition so that you know whether shrinking or extending it broke?

Was the Ubuntu partition _after_ the Vista partition, so that you extended the Vista partition "to the right"?

robuust (robbiecuiper) wrote :

no, i did it alltogether, i didnt test it

yes, it was _after_ :P

Tormod Volden (tormodvolden) wrote :

(marking as confirmed because of upstream bug report)
For the reference, I could repair a similar problem using the "testdisk" program (from universe). There is also related information on http://support.microsoft.com/kb/927392

Changed in gparted:
status: Incomplete → Confirmed
Changed in gparted:
status: Unknown → Confirmed
Matt Hickford (matt-h) wrote :

I too resized an ntfs partition using gparted, and now vista will not boot.
I am running intrepoid

trevjs (trevjs) wrote :

Is it really a bug? I've had this problem before, though it was a Debian installation that borked things up with win xp. The problem, I believe relates to the way some filesystems save things all over the partition, rather than always at the front. I've managed to avoid this problem since by running disk compression utilities. So...

Did people run disk compression until all files were located at the begining of the partition? Sometimes you need to run a third-party compression utility at boot-up in order to move the system files. This is certainly true of fat file-systems, and I'm pretty sure it is also true with NTFS. If you resize a partition like this without compressing the fs, it overwrites parts of the partition (in my understanding).

trevjs (trevjs) wrote :

Oops! I meant to say defragment and not "compress". So "compression utilities" should read "defragment utilities" etc...

Lumenos (spamoiicious) wrote :

I HAVE A PLAUSIBLE EXPLANATION.

See https://bugzilla.gnome.org/show_bug.cgi?id=379482#c35

Lumenos (spamoiicious) wrote :

GParted developer has confirmed this is an incompatibility between GParted and Vista that was fixed with release 0.4.4 see https://bugzilla.gnome.org/show_bug.cgi?id=379482#c37. The OP was using ubuntu 8.10 live cd which uses GParted version 3.8.0 https://lists.ubuntu.com/archives/universe-bugs/2009-January/044941.html

Lumenos (spamoiicious) wrote :

Actually the source made a typo I missed. That should be gparted (0.3.8-1ubuntu2) http://packages.ubuntu.com/intrepid/gnome/ . The point remains. I suppose this "bug" should be closed.

robuust (robbiecuiper) wrote :

okay, great! problem solved (:

Changed in gparted:
status: Confirmed → Fix Released

Thanks. Therefore closing the bug.

Changed in gparted (Ubuntu):
status: Confirmed → Fix Released
Changed in gparted:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.