Gnome Partition Editor

gparted does not like /dev/mapper devices

Reported by Phillip Susi on 2005-09-25
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GParted
Fix Released
Medium
gparted (Ubuntu)
Medium
Unassigned

Bug Description

It seems that gparted does not like working with /dev/mapper devices. I believe
it has something to do with the fact that after updating the partition table, it
issues an ioctl to ask the kernel to re-read the partition table and fix up the
partition devices, but this operation is not supported on /dev/mapper devices.

The symtoms that I have seen so far include:

1) Attempting to resise a partition ( NTFS in this case ) simply did nothing.
When I clicked apply, it appeared to work for a few seconds, then just stopped
with no error message. No changes were made to the disk.

2) If you attempt to create a new partition and format it, the new partition
gets created, but the format fails because the ioctl fails and the new partition
device does not exist. I had to only add the partition, apply, then run the
dmraid utility to re-read the partition table and create the new partition
device, then refresh gparted and then format.

http://bugs.gnome.org/show_bug.cgi?id=317262: http://bugs.gnome.org/show_bug.cgi?id=317262

Daniel Holbach (dholbach) wrote :

Thanks for the bug report, I took the issue to upstream:
http://bugs.gnome.org/show_bug.cgi?id=317262

Phillip Susi (psusi) wrote :

Didn't I read somewhere that gparted is being created as an ubuntu bounty? Then
why was this moved upstream?

The upstream bug also has not been touched since it was created.

Matt Zimmerman (mdz) wrote :

(In reply to comment #2)
> Didn't I read somewhere that gparted is being created as an ubuntu bounty?

No, gparted was developed independently of Ubuntu.

plors (plors) wrote :

'rediscovered' this bug. Could you please take a look at the last comments in
the upstream bug?

thnks :)

Phillip Susi (psusi) wrote :

Done, thanks for the heads up.

Changed in gparted:
status: Unconfirmed → Confirmed
Changed in gparted:
status: Unknown → In Progress
Phillip Susi (psusi) wrote :

Feisty has regressed on this front unfortunately... now it doesn't even show the dmraid devices in the drop down list.

Changed in gparted:
assignee: dholbach → nobody
DAaaMan64 (daaaman64) wrote :

I am just double confirming Phillip's comment. Gparted does not recognize mapper devices at all. That is with dmraid installed and acknowledging software raid.

Danny Wood (danwood76) wrote :

This issue still exists with the latest gparted as of Hardy Heron Ubuntu 8.04

.. and still exists with the latest gparted as of Hardy Heron Ubuntu 8.04.1

Phillip Susi (psusi) wrote :

This is still an issue in Ubuntu's Intrepid Ibex release; dmraid devices are not listed in the drop down box of gparted.

crimescene (foschi-e) wrote :

I comfirm, Gparted don't like dmraid.
in the drop down box the device are called "nvidia_geadaajc1" but is "nvidia_geadaajc", i think it's simple to resolve, gparted just add "1" to partition.

Chris Coulson (chrisccoulson) wrote :

crimescene - I think you have a separate issue (bug #154864)

Curtis Gedak (gedakc) wrote :

Initial support for /dev/mapper dmraid devices has been developed for GParted.

If you are able to help out with testing, please read the following GParted forum post:
http://gparted-forum.surf4.info/viewtopic.php?id=13264

Changed in gparted:
status: In Progress → Fix Released
Curtis Gedak (gedakc) wrote :

GParted 0.4.4 has been released. It includes support for /dev/mapper dmraid devices.

See http://gparted.sourceforge.net/news.php for more information.

This should be fixed in Ubuntu 9.10 since it ships gparted 0.4.5 and the bug has been fixed for gparted 0.4.4. Thanks for reporting.

Changed in gparted (Ubuntu):
status: Confirmed → Fix Released
Changed in gparted:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.