GPA not starting due to Fatal Error in GPGME library

Bug #1257412 reported by intherye
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Gpager
Undecided
Unassigned
gpa (Ubuntu)
High
Unassigned

Bug Description

In a currenty Trusty installation gpa does not start. A popup window opens with:

---------
Fatal Error in GPGME library
(invoked from file confdialog.c, line1455):

  Not implemented

The application will be terminated.
---------
Console output:

$ gpa
** Message: switched engine to `/usr/bin/gpg2'

** (gpa:10442): CRITICAL **: gpa_start_simple_gpg_command: assertion 'argv[0]' failed

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gpa 0.9.4-1
ProcVersionSignature: Ubuntu 3.12.0-4.10-generic 3.12.1
Uname: Linux 3.12.0-4-generic x86_64
ApportVersion: 2.12.7-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Dec 3 19:08:59 2013
InstallationDate: Installed on 2013-11-27 (5 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131127)
SourcePackage: gpa
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
intherye (intherye) wrote :
Revision history for this message
doctordruidphd (doctordruidphd) wrote :

Same problem here.
This happens both on the version downloaded from the repositories, and compiling from source code as well.

Changed in gpa (Ubuntu):
status: New → Confirmed
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

It renders essential functionality of the package (or a dependent one) broken.

Changed in gpa (Ubuntu):
importance: Undecided → High
Changed in gpager:
status: New → Confirmed
Changed in gpa (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Oscar Tiderman (oscar-tiderman) wrote :

This is output from launching from terminal:
oscar@hibbert:~$ gpa
** Message: switched engine to `/usr/bin/gpg2'

** (gpa:25171): CRITICAL **: gpa_start_simple_gpg_command: assertion 'argv[0]' failed

Revision history for this message
intherye (intherye) wrote :

It doesn't happen if I downgrade libgpgme11 to version 1.4.2-0.1ubuntu3 (from saucy).

Revision history for this message
intherye (intherye) wrote :

Seems to be fixed in libgpgme11 (1.4.3-0.1ubuntu5). I don't get the error message anymore.

Revision history for this message
julien.vanneyre (julien-vanneyre) wrote :

What's that trip...i've the same problem...sorry for my UK, i'm from france!

Revision history for this message
intherye (intherye) wrote :

See comment #6.

@Julien: Please update your software and check if the issue is still there.

Changed in gpa (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
intherye (intherye) wrote :

I'm pretty sure the bug does not have something to do with gpager.

Changed in gpager:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers