Can't find imports via GOPATH

Bug #1020991 reported by James Christoff on 2012-07-04
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gorun
High
Gustavo Niemeyer

Bug Description

go run does work on GO1.02, with one flaw. It cannot find import packages in the GOPATH. For example if I have my GOPATH set to the following : $HOME/gocode. gocode contains the 'bin' , 'pkg' and 'src'. my imports reside in 'pkg/darwin_amd64'. Such an import is 'bitbucket.org/binet/gnuplot/pkg/gnuplot.a'. This pkg cannot be found unless I place it in the directory - go/pkg/darwin_amd64/.

In summary, it appears go run does not search in the GOPATH for imports.

Gustavo Niemeyer (niemeyer) wrote :

Indeed, sorry about that. I should have worked on that already.

summary: - go run cannot find imports via GOPATH
+ gorun cannot find imports via GOPATH
Changed in gorun:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Gustavo Niemeyer (niemeyer)
summary: - gorun cannot find imports via GOPATH
+ Can't find imports via GOPATH
James Christoff (j-christoff25) wrote :

I expect this this problem with go run is not on the top of your priority list at this time, however since I use TextWrangler for most of my work with "GO", I check the status of "go run" everyday. If I can be of help resolving this problem let me know. I have tried to correct this problem on may own, but do not know where to start.

Jim

maurizio de santis (izietto) wrote :

My workaround is using `go run` instead of `gorun`: `go run` isn't affected by this bug, no idea why

DdAndKd AtHome (8-darrell) wrote :

I'd love to see this one corrected as well. Using 'go run' has been my workaround as well but it's clumsy workaround.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers