Help -> about = crash

Bug #579319 reported by Chitlesh Goorah on 2009-12-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnusim8085
High
Unassigned

Bug Description

Hello there,

It has been reported on the fedora bugzilla that gnusim8085 crashes when click about menu. I confirm the bug. The backtrace is attrached to this bug report :

https://bugzilla.redhat.com/show_bug.cgi?id=542945

Tags: ui Edit Tag help
Aanjhan Ranganathan (aanjhan) wrote :

I can confirm the crash with svn head. But the Ubuntu package doesnt seem to crash. We might have to check the diff between the two source codes. I remember fixing a similar bug some time back.

@Onkar - Any pointers? I will have a look tomorrow during FOSS.IN

Onkar Shinde (onkarshinde) wrote :

Chitlesh,

Can you please try launching the application form command line and see if it prints anything before crashing?

Chitlesh Goorah (chitlesh) wrote :

No it doesn't print anything except "Segmentation fault"

Backtrace: https://bugzilla.redhat.com/attachment.cgi?id=375010

Chitlesh Goorah (chitlesh) wrote :

I got it fixed and pushed to fedora updates:

# RHBZ = 542945
sed -i \
    "s|share/doc/\${PACKAGE}|share/doc/%{name}-%{version}|" \
    configure.in
sed -i "s|/usr/local/doc/GNUSim8085|%{_docdir}/%{name}-%{version}|" src/callbacks.c

libtoolize --force --copy
aclocal
automake --add-missing
autoconf

Onkar Shinde (onkarshinde) wrote :

Chitlesh,

Can you please explain why you needed to do these changes. There are no hard coded paths in configure.in. Also callbacks.c does not contain any patch to document folder.

Further this looks like a packaging problem to me. It seems that the value of prefix passed to configure script is different than where the program actually gets installed. Also <prefix>/share/doc/<name>-<version> does not look a standard install location for documentation to me. It usually is <prefix>/share/doc/<name> only.

Sridhar Ratnakumar (srid) wrote :

Even if this is a packaging problem, shouldn't the program at least /not/ crash?

Onkar Shinde (onkarshinde) wrote :

Found the problem finally. It was one of those basic mistakes you do when dealing with pointers.

Changed in gnusim8085:
milestone: none → 1.3.7
status: Confirmed → Fix Committed
The Escapist (wisd00m) wrote :

I can confirm that this is still the case for the latest release, I have just reported that this is also happening on Win7 (64) in Win XP/SP2 compatibility mode

The Escapist (wisd00m) wrote :

after removing the "language2.rng" file, and when running in native Win7/64 bit mode, this issue no longer occurs here with 1.3.6

Onkar Shinde (onkarshinde) wrote :

This issue is not related to languages2.rng. It is a null pointer referencing problem. The fix will be available when 1.3.7 is released.

The Escapist (wisd00m) wrote :

yes, I did in fact notice that - yet, when I was running the program in Win XP/SP2 compatibility mode, it would reliably crash - but now that I am running it in 64 bit mode, it's not crashing anymore.

The Escapist (wisd00m) wrote :

This seems to be fixed in the 1.3.7 prerelease that Onkar has provided for testing. However, I should probably note that calling the Help/About dialog is also causing the issue of halting the GUI for 3-5 seconds. I can reproduce this reliably here, it's happening whenever I bring invoke that menu item.

Changed in gnusim8085:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers