Assembler Error: No line highlighting

Bug #519834 reported by Aanjhan Ranganathan on 2010-02-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnusim8085
Wishlist
Unassigned

Bug Description

When the error info in the side pane is clicked, it would be better if the appropriate line is highlighted. Now, just the line number gets bold. If not highlight, may be _some_ indication in the editor pane would help.

Tags: ui Edit Tag help
Sridhar Ratnakumar (srid) wrote :

Good idea. Should be simple to implement as the line number is available in the LineNo column.

Changed in gnusim8085:
importance: Undecided → Wishlist
aniceberg (aniceberg) wrote :

Highlighting would be easy, but when could we remove the highlight on the line? Any suggestions?

Sridhar Ratnakumar (srid) wrote :

We don't have to literally highlight the line (with background yellow, for instance), but simply move the cursor/pointer to that line. That is how most IDEs work, AFAIK.

Aside: we could as well highlight the *current* line (the line in which the cursor is) always. similar to SciTE?

tags: added: ui
Onkar Shinde (onkarshinde) wrote :

Just found out what the problem is. When we click on the line in error info pane the cursor in editor gets placed at appropriate line. Hence the the line number is shown in bold. The reason cursor is not visible is because editor component does not have focus. If you use TAB key to put focus on editor component again the cursor becomes visible.

As suggested by Sridhar, we could use line highlight always. But as of now we specifically use line highlight during debug mode. So always highlighting line could be confusing to users.

Debjit Biswas (debjitbis08) wrote :

Maybe we should shift the focus to the editor element when the error info line is double clicked. Hope that would be simple enough.

As an aside, I noticed that the whole application window UI breaks when there are long error messages. We must wrap the message list inside a ScrolledWindow

Onkar Shinde (onkarshinde) wrote :

Debajit,

Shifting focus is not easy. Rather as Sridhar suggested, highlighting the line with error is easy. Only thing I need to figure out is how (and when) remove highlighting from editor. Probably it is best to remove it when user clicks Assemble/Exedcute because that means user has tried to correct error.

I will take a look at the message wrapping issue.

Debjit Biswas (debjitbis08) wrote :

Onkar,

Highlighting the error line on clicking the error message seems nice. My suggestion would be to remove the highlight once the user has edited the source. This is something that I have observed in many editors.

Changed in gnusim8085:
status: New → Confirmed
milestone: none → 1.3.7
Onkar Shinde (onkarshinde) wrote :

Three lines of code change fixed this issue. Now when user clicks an error message in message pane, the line in editor will be highlighted.

Changed in gnusim8085:
status: Confirmed → Fix Committed
Changed in gnusim8085:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers