Domains overlap

Bug #610762 reported by Stéphane List on 2010-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnuclad
Medium
Donjan Rodic

Bug Description

Hi Donjan,

I'm testing the new fresh version 0.2.

I still have a problem with domains overlapping, my config and result files are here :
http://slist.lilotux.net/linux/sldt-0.2/

And by adding some more spaces between domains, it's more visible, the green is on the blue :
http://slist.lilotux.net/linux/sldt-0.2-overlap/sldt.svg

By the way, the asciiStrings option seems to work fine except for number, see "0.4", should I open a new bug or reopen the old one ?

Regards

Stephane

Donjan Rodic (bryonak) on 2010-07-28
Changed in gnuclad:
assignee: nobody → Donjan Rodic (bryonak)
importance: Undecided → Medium
status: New → Confirmed
Donjan Rodic (bryonak) wrote :

Hey Stephane

Thanks for the report.
I've missed to check for proper domain building with optimise=0 and the treeMode you use.

The bug is now fixed, but I plan a few other changes so the bugfix release will take some days.
If you want to try it right away, check out the bazaar branch (via bzr or the web interface at http://bazaar.launchpad.net/~bryonak/gnuclad/trunk/files ...you can replace your src/gnuclad-cladogram.cpp with the one from the current branch, as this is the only one affected by this bug).

Besides, you may want to use "appendYears = 1" in your config file.

As for the asciiStrings... I'm going to do some testing and increase the calculated width for numerals.
It'd be nice if you could open a new bug with precise information about which characters don't work for you :)

Changed in gnuclad:
status: Confirmed → Fix Committed
Donjan Rodic (bryonak) wrote :

Just did another update for better handling of huge values for treeSpacing. If you download src/gnuclad-cladogram.cpp, make sure it's Latest Rev is at least 85.

Donjan Rodic (bryonak) wrote :

0.2.1 is out, so I'll mark this as fixed.

Changed in gnuclad:
status: Fix Committed → Fix Released
Stéphane List (slist) wrote :

Hi Donjan,

Thanks for your reactivity !
Yes it's corrected because it doesn't overlap anymore, but there's now a problem of color !

In inkscape, the green domain is invisible.
In firefox, the green domain is black !

http://slist.lilotux.net/linux/sldt-0.2-overlap/sldt-gnuclad-0.2.0.svg
http://slist.lilotux.net/linux/sldt-0.2-overlap/sldt-gnuclad-0.2.1.svg

Donjan Rodic (bryonak) wrote :

I've tried to streamline the escaping of invalid XML chars... and it seems the whitespace is also kind of invalid (although not mentioned as a reserved entity in the XML spec, it still breaks SVG references).

Should be fixed now, let me know if you find anything else.
https://launchpad.net/gnuclad/+download

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers