Doubled menu items whenever

Bug #602177 reported by alexandrius on 2010-07-06
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GnoMenu
Medium
Unassigned

Bug Description

The doubled menu is generated after installing any kind of app
here's screenshot
http://i47.tinypic.com/nx1jch.jpg
I've to restart applet to have normal menu

alexandrius (dze-master) wrote :
technoshaun (shaun-marolf) wrote :

Are you using GnoMenu in KDE by chance?

Changed in gnomenu:
status: New → Triaged
importance: Undecided → Medium
alexandrius (dze-master) wrote :

@ technoshaun
Nope in Gnome

technoshaun (shaun-marolf) wrote :

What distribution?

alexandrius (dze-master) wrote :

@technoshaun
Ubuntu lucid

technoshaun (shaun-marolf) wrote :

Okay update to GnoMenu 2.9 now that its released and if you still have the issue let me know the following:

What desktop environments you have besides Gnome, if any others.
What other third party menu programs you have installed
What launchers you have like Cairo, Docky, AWN, etc

Thanks for working with us on this.

alexandrius (dze-master) wrote :

@technoshaun
Whooray! Problem is solved :)
I am using it on AWN and have installed E17

-->Thanks for working with us on this.
Thanks to YOU for awesome application like this :)

-Regarding Alex

Changed in gnomenu:
status: Triaged → Fix Released
technoshaun (shaun-marolf) wrote :

I have reported a bug few days ago, the bug was fixed but now i found out that if app install with apt-get or apt-url the doubled menu appears again

-Regarding alex

Changed in gnomenu:
status: Fix Released → Triaged
technoshaun (shaun-marolf) wrote :

I just installed abiword using apt-get and I'm not getting the double menu entry. So there has to be another cause and we need to find it. So now we go back to where we started:

What desktop environments you have besides Gnome, if any others?
What other third party menu programs you have installed?
What launchers do you have like Cairo, Docky, AWN, etc?

alexandrius (dze-master) wrote :

I removed E17
Non of third party menu programs are installed
Using AWN

alexandrius (dze-master) wrote :

I've just installed RedshiftGUI and menu doubler bug once again revealed itself :(

technoshaun (shaun-marolf) wrote :

When you restart GnoMenu does it clear up?

alexandrius (dze-master) wrote :

Yes

alexandrius (dze-master) wrote :

I'm really puzzled today i installed app from software center and menu doubled :|

technoshaun (shaun-marolf) wrote :

Okay lets try this. If you restart GnoMenu after an install it clears the issue. I, on the other hand, sometimes have to restart GnoMenu to see what I just installed. So you have something in your configuration, or setup that affects how Gnome Main Menu does things that is different than mine. So we need to look at what that is.

One of the project goals is to create consistency in how things are handled, within reason of course. So if we can nail down the culprit that causes this then we can, hopefully, fix it. Even if we can't we can, at the very least, list it as a known issue.

So the best place to start is look at any programs and plugins you have that have any affect on Gnome Main Menu, starting with configuration programs. Can you please give me a list of any tweak, configuration apps and plugins you have designed to work with the menu system in Gnome.

alexandrius (dze-master) wrote :

@technoshaun
I installed a new app and checked all of the menus:

Yet another menu applet - doubled
http://i27.tinypic.com/14udjx2.jpg

Cairo menu applet - not doubled (but sucks :D)
http://i29.tinypic.com/2nlzndt.jpg

AWN Menu applet - not doubled (also sucks)
http://i26.tinypic.com/2elf7d4.jpg

GnoMenu is also doubled

I have played yearlier with .desktop files in home folder (where actually the menu exists)
I have Ubuntu tweak installed

This is what may effect doubling menu (from terminal log)
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
The GnoMenu and Yet another menu don't refresh DB correctly, maybe

P.S Tomorrow i have last national exam :@

technoshaun (shaun-marolf) wrote :

Okay that Menu App appears to be the main Gnome Menu which definitely indicates its an issue outside of GnoMenu itself and may be related to the following Bug #12040 ( vhttps://bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/12040 )for Gnome Main Menu. Not absolutely sure but if we turn off menu caching in Gnome it may solve your issue.

alexandrius (dze-master) wrote :

There are so many comments can you please concretely say which of the comments would fix my problem and how do i disable menu caching? Sorry for disturbing

alexandrius (dze-master) wrote :

Doesn't help :(
I'll reinstall my system these days

Thanks anyways

technoshaun (shaun-marolf) wrote :

Well your bug just happened to me so now the hunt is on to find the cause on my end. Since I can trace my system.

Changed in gnomenu:
status: Triaged → Confirmed
Dylan Coakley (dylan-coakley) wrote :

I was just about to report this bug.

I can also confirm this is happening on my system. (after apps get updated)

markoER (marko-rakamaric) wrote :

hi to all!!!

i am reporting this double menu bug too.

OS: Lucid
gnomenu v2.9

bug is only shown when new application is instaled, or when doing any update.

csw840915 (csw840915) wrote :

Hello everybody,

I can confirm that I have the double icons issue on every Ubuntu distribution that I install Gnomenu. I distribute Ubuntu to our clients, depending on the clients pc I issue the different distro versions. LIke 8.04, 8.10, 9.04 & 10.04. All these distributions have the same problem with the Gnomenu. The double icon problem is with Gnomenu. Please can you look into this. Its real annoying and drives my clients away from using this flashy looking menu. I really like Gnomenu and hope to see this bug fixed. Thank you kindly. Regards, Clinton

nobody-none (none-nobody) wrote :

this problem frequently happens to me, too.
It really doesn't bother me, but we should still fix it. I like GnoMenu A LOT!!!!
:)

nobody-none (none-nobody) wrote :

this happens in ubuntu 10.10 to me

summary: - Doubled menu items after installing app
+ Doubled menu items whenever
Eric Bergman (e-bergman-bsa) wrote :

I also have this problem, I'm using Fedora 14 x86_64.

The last version (which has the double menu items bug) was released on 2010-07-07.
Is this project discontinued?

Edward (undrline) wrote :

I have the same issue: Ubuntu Lucid 10.04, Gnome only. I have Docky. I think I did something with Compiz to get the extra desktop effects. I have installed KDE items, such as kturtle. It pretty much always has the double set of menu items unless Gnomenu just initiated. I don't believe it's necessarily related to installing something new. I restarted Gnomenu before I installed kturtle just to see. I did the same for uninstalling stellarium. Neither made it an issue. I haven't seen any pattern, myself.

This is a known bug with gnome-main-menu, which gnomenu relies on for menu
listings. There is a work around fix. The problem is dual menu listings
(not entries) and you need to ignore the KDE list.
On Nov 24, 2011 6:55 PM, "Edward" <email address hidden> wrote:

> I have the same issue: Ubuntu Lucid 10.04, Gnome only. I have Docky. I
> think I did something with Compiz to get the extra desktop effects. I
> have installed KDE items, such as kturtle. It pretty much always has
> the double set of menu items unless Gnomenu just initiated. I don't
> believe it's necessarily related to installing something new. I
> restarted Gnomenu before I installed kturtle just to see. I did the
> same for uninstalling stellarium. Neither made it an issue. I haven't
> seen any pattern, myself.
>
> --
> You received this bug notification because you are subscribed to
> GnoMenu.
> https://bugs.launchpad.net/bugs/602177
>
> Title:
> Doubled menu items whenever
>
> Status in GnoMenu - consolidated menu for gnome:
> Confirmed
>
> Bug description:
> The doubled menu is generated after installing any kind of app
> here's screenshot
> http://i47.tinypic.com/nx1jch.jpg
> I've to restart applet to have normal menu
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnomenu/+bug/602177/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Bug attachments